1

I want to install mysql-server 5.6 on RHEL 5.8, but when trying rpm -i or rpm -Uvh it complains that I already have version 5.0 on there. I am happy to replace, upgrade or install another instance.

  • Have you searched or tried anything else around accomplishing this? – slm May 5 '14 at 4:08
  • I also tried MySQL's yum repo, but it seems to not have version 5.6 This sounded easy before I began actually trying to do it. It has been surprisingly tough. Perhaps I should just do yum erase mysql-server and then rpm -i the RPM that I have. – Gregg Leventhal May 5 '14 at 5:07
  • That's what I would do, especially if you have the DB and .conf files backed up. – slm May 5 '14 at 5:48
2

I've done the follow routines and upgraded to Mysql-server 5.5 successfully on CentOS 6.5.

  1. yum remove mysql mysql-*
  2. rpm -Uvh http://dl.fedoraproject.org/pub/epel/6/x86_64/epel-release-6-8.noarch.rpm
  3. rpm -Uvh http://rpms.famillecollet.com/enterprise/remi-release-6.rpm (choose your relevant Remi repo)
  4. yum --enablerepo=remi,remi-test install mysql mysql-server
  5. service mysqld start
  6. mysql_upgrade -u root -p

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.