2

The Quick Filter window displays by default the text Filter These messages... <Ctrl+Shift+K> as displayed on the attached screenshot.

enter image description here

The text disappears when I start typing into the window, but reappears again when the text in the window is deleted.

I find the text distracting. Is there any way to remove it? I would like to have an empty window with no text.

I am using Thunderbird 24.4.0

  • Just keeping things connected, the OP asked this Q on mozillazine as well: forums.mozillazine.org/viewtopic.php?f=39&t=2824577 – slm May 9 '14 at 4:56
  • @slm - I have not received any reaction on mozillazine for one week, so I have posted the same question here, and added a bounty. – Martin Vegter May 9 '14 at 6:12
  • Yeah I noticed, I was putting the link here just in case someone else ever googles either of these things they'll stumble into the other. – slm May 9 '14 at 6:14
1
+50

Yes, there is a way to remove it.

I quickly hacked together a simple addon that does this via an XUL Overlay specified in its chrome.manifest. I don't see a good way to achieve this without an addon or modifying files.

Technical details:

The original file, chrome/messenger/content/messenger/quickFilterBar.xul located inside omni.ja sets the text with the following XUL tag using the attribute emptytextbase (on line 139, for Thunderbird 24.5.0):

<textbox id="qfb-qs-textbox" flex="1"
         type="search"
         placeholder=""
         emptytextbase="&quickFilterBar.textbox.emptyText.base;"
         ...

Just for reference: &quickFilterBar.textbox.emptyText.base; is defined in chrome/<lang>/locale/<lang>/messenger/quickFilterBar.dtd, also located inside omni.ja.

The XUL Overlay inside my addon changes the text to an empty string with the following line:

<textbox id="qfb-qs-textbox" emptytextbase=""></textbox>
  • so what do I need to change and where? I see a file /usr/share/icedove/omni.ja but it looks like a binary file. Is there any way to do it without installing your addon? – Martin Vegter May 10 '14 at 21:22
  • 1
    You need to unpack the omni.ja using a zip decompressing utility (unzip works, 7-Zip fails). Then you can modify chrome/messenger/content/messenger/quickFilterBar.xul, changing line 139 from emptytextbase="&quickFilterBar.textbox.emptyText.base;" to emptytextbase="", and last re-pack the omni.ja with zip -qr9XD omni.ja *. One other way to do this without using my addon is to look at my addon and create your own. Please note though, that if you don't use an addon but modify the omni.ja you will have to repeat this procedure every time you update Thunderbird. – Michael Ehrenreich May 10 '14 at 22:28
  • thanks a lot for the instructions. Modifying chrome/messenger/content/messenger/quickFilterBar.xul as described by you did not have any effect. But I have solved the problem by editing chrome/en-US/locale/en-US/messenger/quickFilterBar.dtd and setting <!ENTITY quickFilterBar.show.key2 ""> and <!ENTITY quickFilterBar.show.key2 "">. – Martin Vegter May 11 '14 at 8:20

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.