I've just installed QT 5 in Arch Linux, but only qtconfig doesn't work:

%> qtconfig
qtconfig: could not exec '/usr/lib/qt/bin/qtconfig': No such file or directory

Yes, there's no such file, not even /usr/lib/qt5/bin/qtconfig

Any ideas where to locate it? I need to adjust the font of smplayer, which is linked with QT 5 libraries now.

4 Answers 4


qtconfig no longer exist in Qt5. Qt5 applications will use the current desktop settings by default, but it doesn't work perfectly. For instance I'm using XFCE and it doesn't automatically set the style to Gtk.

The style can be set with the -style command line option, for instance -style=gtk . Or you can use a specific Qt stylesheet with -stylesheet. You can see the available options in QApplication documentation. Also :

You can also set the style for all Qt applications by setting the QT_STYLE_OVERRIDE environment variable.

For smplayer, you can change the default font and style used in the menu Option > Preferences > Interface.

  • Sadly, QT_STYLE_OVERRIDE does not seem to work for me. I'm using keepassx, and when launched as keepassx -style=gtk it works, but QT_STYLE_OVERRIDE=gtk keepassx does not. I've also tried exporting the environment variable elsewhere, and it still does not get picked up :(
    – Johann
    Commented Jul 15, 2017 at 1:20

The solution that worked best for me is qt5ct, which is currently available in the standard Arch community packages. It's a DE-independant Qt5 configuration utility similar to the old qtconfig.



this here does its job: https://www.archlinux.org/packages/community/x86_64/lxqt-config/

not packaged, afaik: http://qt-apps.org/content/show.php/Qt5+Configuration+Tool?content=168066

  • Your first link appears to be broken.
    – JAB
    Commented Jan 27, 2016 at 22:01

See https://wiki.archlinux.org/index.php/qt

Qt packages do not provide the usual bin (e.g. qmake) in /usr/bin anymore.

Instead -qt5, -qt4 and -qt3 symlinks are provided (e.g. qmake-qt5, qmake-qt4, qmake-qt3).

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .