2

Init typically will start multiple instances of "getty" which waits for console logins which spawn one's user shell process. Upon shutdown, init controls the sequence and processes for shutdown. The init process is never shut down. It is a user process and not a kernel system process although it does run as root. If the init process are user process and not kernel process, how I can modify the behavior or see the log the the process remotely?

  • "see the log the the process remotely" What does this part mean? Also, how are you wanting to modify its behavior? Depending on what getty program your distribution uses, you can usually change the command line arguments given to it by modifying /etc/inittab – Bratchley May 2 '14 at 21:04
  • I'm on a ubuntu and I'm trying modify the numbers of getty with # ln -sf /usr/lib/systemd/system/getty@.service /etc/systemd/system/getty.target.wants/getty@tty9.service # systemctl start getty@tty9.service just now is working, but wish know what changes are ocurring in the process. – MrMins May 2 '14 at 21:08
0

To clarify, you seem to be running systemd on Ubuntu rather than the (current) default of upstart.

systemd, by default, sets up only one getty, tty1. Other gettys are set up "on the fly". There is a default setting of a maximum of 6 ttys.

If you want to increase the number of gettys available to autostart, then increase the value of NAutoVTs in /etc/systemd/logind.conf.

If you want to prestart gettys, continue to do what you are doing (i.e. enabling a getty service and starting it) for each getty you want. Not sure why you want to preactivate though.

More details available here:

https://wiki.archlinux.org/index.php/Systemd_FAQ#How_do_I_change_the_default_number_of_gettys.3F

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.