3

I am increasing nproc limit for one of a development user account in my rhel6 system . After searching some rubust solution , I zerod at editing /etc/security/limits.conf with these two lines :

@dev_user        hard    nproc          4096
@dev_user        soft    nproc          4096

For some cases I have to deal with so much number of threads that's why I want those numbers high . Also this solution serves the pupose well . BUT my problem is if any time I edit that file with sudo permission then it only becomes after the system restart.

This dev_user have been provided root access with sudo permissions only. Here is my humble request to you to please suggest me some solution which should do the task without restart . Also increased limits should last long until unless no else edits it again.

  • Restarting the entire system for a limits.conf change to take effect is like burning down your whole house to get rid of a spider. – Bratchley May 2 '14 at 13:04
4

The settings specified in /etc/security/limits.conf are applied by pam_limits.so (man 8 pam_limits).
The pam stack is only involved during the creation of a new session (login). Thus you need to log out and back in for the settings to take effect.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.