2

I installed Debian wheezy with XFCE 4.8 on my new laptop, updated the kernel to 3.13 from backports.

When I connect the laptop to my monitor, I can see only a part of the screen on the monitor with a very low resolution. On my old laptop, I used to fix that using XFCE display settings or ARandR but now both don't detect the new monitor even though its obviously working.

I didn't install any proprietary drivers. I don't have xorg.conf. Here is the output of xrandr:

xrandr: Failed to get size of gamma for output default
Screen 0: minimum 1920 x 1080, current 1920 x 1080, maximum 1920 x 1080
default connected 1920x1080+0+0 0mm x 0mm
   1920x1080       0.0* 

Here is the (hopefully) relevant output of lspci:

00:02.0 VGA compatible controller: Intel Corporation Haswell Integrated Graphics Controller (rev 06)
01:00.0 3D controller: NVIDIA Corporation Device 1292 (rev a1)
1

I suggest installing Nvidia Graphics Drivers:

  1. Add "contrib" and "non-free" components to /etc/apt/sources.list:

    deb http://http.debian.net/debian/ wheezy main contrib non-free
    
  2. Update the list of available packages and install the appropriate linux-headers and kernel module packages:

    $ aptitude update
    $ aptitude -r install linux-headers-$(uname -r|sed 's,[^-]*-[^-]*-,,') nvidia-kernel-dkms
    

More info: https://wiki.debian.org/NvidiaGraphicsDrivers

  • I tried nvidia-detect first as the wiki suggests but it says: No NVIDIA GPU detected. – Omar Tarabai May 3 '14 at 21:13

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.