6

I have a screen capable of 2560x1440. It is connected to my Intel NUC with a DP to DVI adapter. My graphics card Since updated my Arch Linux system last week (not sure what was updated exactly) I can no longer use the highest resolution. I'm pretty sure I could only use 1080 before then and the screen complained that I used the wrong cable so something was still weird back then but I didn't think about it much. Now I can only use 1680x1050 which is unreadable on my screen and disrupts my work.

Here is my lspci, xrandr and xorg log: http://pastebin.com/5aSwQrk1

I find it strange that xrandr lists 2 HDMI ports, I'm not using HDMI at all and have even tried to disable it in BIOS. For some reason "DP1" is also listed as disconnected. DP1 seem to have some relation with HDMI2 as both are listed as "Clones" of each other, I have no idea what that means though.

As you can see from the xorg log it even detects the correct modes:

[   184.333] (II) intel(0): Printing DDC gathered Modelines:
[   184.333] (II) intel(0): Modeline "2560x1440"x0.0  241.50  2560 2608 2640 2720  1440 1443 1448 1481 +hsync -vsync (88.8 kHz eP)

I've tried adding that modeline manually to HDMI2, but it failed:

$ xrandr --newmode 2560x1440  241.50  2560 2608 2640 2720  1440 1443 1448 1481 +hsync -vsync
$ xrandr --addmode HDMI2 2560x1440
$ xrandr --output HDMI2 --mode 2560x1440 --verbose
screen 0: 2560x1440 675x379 mm  96.28dpi
crtc 0:    2560x1440  59.95 +0+0 "HDMI2"
xrandr: Configure crtc 0 failed
crtc 0: disable
crtc 1: disable
crtc 2: disable
crtc 3: disable
screen 0: revert
crtc 0: revert
crtc 1: revert
crtc 2: revert
crtc 3: revert

Now I'm completely stuck and need someone with more xrandr and X11 esoteric knowledge to help me.

Thank you for your time.

EDIT: I just tested all variations of the 2560x1440 mode with different MHz settings through xrandr. Above ~165 MHz I get "xrandr: Configure crtc 0 failed" and "(EE) intel(0): failed to set mode: Invalid argument" in the xorg log. Below ~165 MHz switching to the mode works but my screen will go blank and complain "OUT OF RANGE". It's also worth mentioning that 1920x1080 doesn't work either as xrandr returns "configure crtc 0 failed" for it as well, probably because it's above 165 MHz. Driver issue? I'm going to buy a mDP to DP cable tomorrow and try what happens when I don't use DVI.

  • Did you ever make this work? If so, can you share your solution? – marcvangend Aug 28 '14 at 6:51
4

For 2560x1440 you need an active DP to dual-link DVI adapter and a dual link DVI cable. Most likely you only had a passive DP to single-link DVI adapter.

  • One-to-two line answers are often improved with further explanation. Consider expanding your post with documentation that supports your suggestion. – HalosGhost Oct 7 '14 at 17:05
  • 1
    Yes, the cable/link was the problem. I bought a mDP to DP cable instead which works great. Now avoiding DVI/HDMI as much as possible. – Hannes Landeholm Oct 24 '14 at 21:27

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.