5

I've been doing a lot of looking around forums for different ways to unblank the screen. I am running embedded linux on a machine I have and I found out that the screen goes blank under certain conditions. I have my suspicions that this has to do with consoleblank but I haven't been able to find a way to reproduce the blanking consistently by either using setterm, or even changing the kernel parameters on bootup.

So I'm trying to approach this from a different angle. I have my machine in the blanked state and I'm trying to wake it up to see if it is possible. Mouse input won't work, so I have telnet'ed into the machine and I am trying to wake it up.

Running the command:

setterm -blank poke

returns "cannot force unblank" the following also produce that output:

setterm -term linux -blank poke
setterm -term linux -blank poke > /dev/tty02
setterm -term linux -blank poke > /dev/fb2

and a couple other variations do as well.

How can I force my machine to unblank its screen?


UPDATE

I have been looking into this screen blanking issue for over 2 days now and I finally at least found a way tp replicate the blanking. If I locally or remotely log into the system and do this: echo "4" > /sys/class/graphics/fb1/blank The screen blanks, input won't wake it up as per the case that comes up when I'm not expecting it. Then to unblank the screen I can do the following: echo "0" > /sys/class/graphics/fb1/blank

This is all fine and dandy, but If I leave my machine on and it happens to blank the screen on its own, performing the second command does not wake up the display.

The case where the blanking happens on its own is what is concerning me obviously and I am trying to determine what might undo it so that I can look more into preventing it from ever blanking in the first place.

  • No idea, but I assume you've gone into your power management setup and turned off the scenarios that turn the screen off after a period of time of inactivity to save power. – Joe May 6 '14 at 7:25
  • I have been trying to, but none of them seem to address this particular blanking instance. To make sure that I am changing the right values I have been modifying the values so they are very small and trying to make it happen more frequently. This has not produced anything yet though :\ I'm currently fiddling with the kernel to see if I can remove blanking all together though so hopefully that will do it ;) – TopGunCoder May 6 '14 at 12:39
  • Aw, in x it was pretty easy with xset dpms force on weird that you still don't have a good answer to this. – Cestarian Feb 28 '16 at 12:53
3

try

setterm -term linux -blank poke < /dev/tty0 

tools like setterm and stty traditionally take the terminal to process from stdin not stdout, and running setterm under strace shows that this is true.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.