5

On Debian, Shift+Down in URxvt opens new tab. But recently I started using another machine with Fedora, and here it has no effect; here Ctrl+T does that. But neither one works on both, so I'm doomed to think of where I am. Plus, I need Ctrl+T in some programs (Vim, MOC...).

Inspired by a document on ArchWiki, I tried to add URxvt.keysym.Shift-Down: perl:tabbedex:new_tab to my ~/.XDefaults, but that did not have effect. (But even if it did work, I'm not sure if it would release Ctrl+T for other use.)

Any ideas?

3
+100

The ArchWiki comments are describing a different tab implementation for rxvt-unicode called "tabbedex". If you look closely, you'll notice that it's a separate package. If you want to try it out, grab the Perl source and shove it in ${HOME}/.urxvt/ext (see the perl-lib config item in rxvt-unicode(1)).

The package maintainers in Fedora appear to have decided to include this distro-custom patch:

keysym 0x74, BTW, is t. You can supersede the system tabbed Perl extension by putting a copy of /usr/lib/urxvt/perl/tabbed from a Debian machine into ~/.urxvt/ext on your Fedora machine or simply replacing the system copy.

Honestly, what prompted the Fedora patch? I have no idea.

4
  • Thanks for pointers. However, using Debian's tabbed only removes the Ctrl+T, so I end up with no shortcut at all. May 12 '14 at 14:27
  • You're right; I didn't realize the shift+up/down in the fedora build was hardwired in. Have you considered writing a patch for rxvt-unicode upstream making the feature a command-line - or at least, X resources option?
    – etherfish
    May 14 '14 at 7:22
  • see my update: Fedora devs responded with great speed, and removed the patches that broke the original, upstream-like behavior. May 14 '14 at 14:42
  • Fantastic news! Congratulations.
    – etherfish
    May 15 '14 at 7:34
0

Thanks to etherfish for pointers. I have done some more research:

Turns out that this has been broken by an RFE, which introduced first version of another patch, which enabled S-down/up to scroll one line, thus broke the tabbing.

Later this has been addressed few times (e.g. by editing the patch and trying to change that to C-up/down), but that was not really accepted so currently the situation is not solved, save for adding C-T, presumably as a hotfix (... better than no shortcut at all).

I have posted this as bug against Fedora

So what can we do now?

  • Wait for Fedora maintainers to fix the problem (or propose another patch).

  • Build urxvt yourself from upstream.

  • Use different version of tabbed, like tabbedex.

  • Use local copy of tabbed, adding a third shortcut that works on both distros (either add that to ~/.urxvt or edit the system-wide file).

Update: Awesome, about a day later, patch to the bug is already submitted and on its way to release. Patches that broke this on Fedora are being removed so that S-Down will soon work again. Thanks, Fedora devs!

0

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.