1

I had windows on my laptop and installed Debian GNU/Linux a few weeks ago on it. I'm basically dual booting.

The thing is, in my windows I had a windows.old file I never bothered to delete until a day ago. When I deleted it and restarted my laptop, only Linux is shown and I can only boot into linux. Which is fine honestly, but I would love to still be able to get into windows.

Does anyone know what I should/could do to fix my issue?

EDIT After reading some related posts about this issue, I have to say I did delete the .ini files that were there too, I was even prompted if I should delete them or not when I was deleting windows.old, I assumed my new windows install would have them. Hope this info helps.

EDIT 2 - Very weird edition

Okay.. so I run Debian on both my laptop and desktop. I boot up my desktop today and upon boot up I was pressing the numlock key before a screen even appeared. I did this since I usually have 3-4 seconds before it automatically boots into linux. hitting numlock enables my arrow keys and i can then choose Windows 7 instead.

Well.. hitting numlock apparently did the exact thing I mentioned above on my laptop. I only now see Linux and no windows. The reason this stands out is because I was doing the same thing on my laptop before windows 7 disappeared. I think this is the culprit.

But googling the issue shows no solution..

this is odd..

1

First: I'm assuming you use grub as bootloader.

Have you tried to reinstall grub?

grub-install /dev/sdX

where sdX is your boot device. Make sure the os-prober package is installed so grub can find your windows installation.

BTW: deleting the windows.old folder isn't such a good idea. You should clean your drive as described at http://www.eightforums.com/tutorials/2527-windows-old-folder-delete-windows-8-a.html

  • 1
    If Space Ghost is using Debian, issuing sudo update-grub (or update-grub as root) should detect all Linux kernels and Windows bootloaders on the system. Reinstalling grub can sometimes cause issues. I'd suggest running update-grub first. – ChrisR. Apr 30 '14 at 6:21
  • Yeah that's what I ended up doing and it worked like a charm. Thank you. – Space Ghost May 1 '14 at 13:19
0

When pressing the numlock(or maybe any other) key before the GRUB loader even shows up, windows completely disappears for me. I believe this is because Linux suspects that the keyboard is kaput or something.. I really don't know why.. but either way, windows disappears and only Linux is on the grub loader and no matter how many restarts, it never shows up.

The solution is this

sudo update-grub

windows 7 will be found and you may restart your computer, on boot up, windows will again be shown.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.