5

I have a up-to-date Arch Linux and Canon drivers installed from the AUR (cndrvcups-lb). At work I have a Canon iR-ADV C5235 printer, that I want to get working.

I added the printer via the cups webinterface, selected the correct driver and all, but on every print I only get

**** Unable to open the initial device, quitting

After some research I found that the error is related to Ghostscript, but I have no idea how to fix this.

I also tried the ppd files from the Canon website - but then nothing prints at all.

1

Method2 mentioned in the above link worked for me. The problem is caused by missing dependencies of i386 packages, as the above link mentioned.

To verify, check the output of the following command:

dpkg -L cndrvcups-ufr2-uk cndrvcups-common | xargs ldd 2>/dev/null | grep "not found"
0

Just had the same issue, under Debian, after removing i386 on a 64 bits OS. You may check that all i386 packages are available.

I know you're under Arch Linux, but that may be the same issue.

See the Debian page, it may help you find a solution: https://wiki.debian.org/PrinterDriver/Canon/UFR-II (using Method 2, I got rid of the error)

0

I had the same issue with Canon UFR driver.

For me this was solved after upgrading Canon UFR driver to the latest version. For some reason previous version of a driver had ppd files for all the models, but the driver itself only supported some of them. Newer version supported more, including the one I had.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.