2

First Error, when connecting the drive or attempting to mount it manually:

Mount is denied because the NTFS volume is already exclusively opened. 
The volume may be already mounted, or another software may use it which
could be identified for example by the help of the 'fuser' command.

So we try to umount it and get:

umount: /var/run/media/blah/foo: mountpoint not found

So we add a mountpoint somewhere else and try mounting there, and get the first error, then try umounting again, and get:

umount: /var/run/media/blah/foo: not mounted

... no reference to the location I gave it on the mount - /media/foo (a location that exists) - but no complaint that the mountpoint is 'not found' this time.

If I check with the mount command, it does show the device mounted:

/dev/sdb1 on /var/run/media/blah/foo type fuseblk
(rw,nosuid,nodev,relatime,user_id=0,group_id=0,default_permissions,
allow_other,blksize=4096)

Yet umounts fail. The 'force' option does nothing in any of these cases.

So, it seems the device is 'already mounted' if I want to mount it, as evidenced by the output of 'mount' - but not mounted if I want to umount it.

Note, the device was NOT connected to a Windows that hibernated, and running the command to delete the hibernate file (worth a shot) fails again with the 'not mounted' error. Also, the FAT32 partition on the same device works fine.

Ideas please? Thanks.


Months later, still no idea why this happens. I can plug it into an old windoze 2k box, and it mounts just fine. I ran disk-checking there, but found no problems.

I should have added above that running 'fuser -c /var/run/media/blah/foo returns:

Specified filename /var/run/media/blah/foo does not exist

The lsof command simply returns empty (grep'd for any part of the path).

In theory, no processes could possibly be using that device/mountpoint. If they are, I have no idea how to find them, given fuser doesn't know. Neither does lsof.

Also, not running NSF, and "losetup -a" returns nothing.

2 Answers 2

2
  1. First you check: lsblk

    So here you will get block is mounted to particular location

  2. So first unmount the drive:

    niraj1@ns2:/$ sudo umount /media/niraj1/BC1C0B701C0B24CC
    
  3. Then mount the drive:

    niraj1@ns2:/$ sudo mount /dev/sdb1 /media/usb
    

Hope this will fix your issue.

2
  • What mount type did you use to mount the device? Commented Jul 29, 2017 at 17:57
  • In a similar situation i was using the "could be identified for example by the help of the 'fuser' command" like sudo fuser -m /dev/sdb3 without any result, then lsblk just revealed the existing mount point in /media/root/ directory. Thank you!
    – eapo
    Commented Apr 1, 2019 at 0:55
0

Just an addendum to Niraj's answer. My drive was listed as 'Seagate Expansion Drive':

sda           8:0    0   1.8T  0 disk 
├─sda1        8:1    0   250G  0 part /media/jasonl/Seagate Expansion Drive

When I tried to unmount it, as I expected, the spaces in the name caused the umount command not to work:

$ sudo umount /media/jasonl/Seagate Expansion Drive
umount: /media/jasonl/Seagate: no mount point specified.
umount: Expansion: no mount point specified.
umount: Drive: no mount point specified.

The solution of course was to escape the spaces:

$ sudo umount /media/jasonl/Seagate\ Expansion\ Drive
#now this works:
$ sudo mount /dev/sda1 /mnt/seagate

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .