21

I just installed Arch Linux following a video tutorial from youtube for the first time. However, when I try starting the GNOME terminal it won't start. It will say Terminal at the top of my screen for a couple of seconds and there will be a loading symbol, but after a couple of seconds they both disappear and no terminal will appear. Because I can't load or start the terminal I can't do anything (I can't even answer the question to register to the Arch Linux forums). What am I doing wrong?

  • 9
    1. You should use the Arch documentation to install Arch: youtube guides are either wrong, out-of-date or both. 2. What terminal are you trying to start, and in what Desktop Environment? – jasonwryan Apr 27 '14 at 18:08
  • I am using the gnome desktop and am trying to load it's default terminal – Dirk Apr 27 '14 at 18:16
  • 1
    Make sure your locale is set correctly (see the note in the troubleshooting section). – jasonwryan Apr 27 '14 at 18:21
  • How can I edit it without using a terminal? – Dirk Apr 27 '14 at 18:30
  • 1
    You really should be running a more newbie-friendly distro... You can edit files from the TTY using nano or vim... – jasonwryan Apr 27 '14 at 19:06
27

I had the same issue after a fresh install of arch. I checked, double checked and triple checked the locale.gen and even removed every locale except en_US.UTF-8. I was just about to give up when I checked under settings, Regions & Language and discovered the language was not set even though I had run the command to set it. After picking english and rebooting it works fine.

15

Sounds like you messed up your /etc/locale.gen file.

If you are english/US, comment out any of the other entries in that file, UNLESS YOU NEED THEM. They are for other languages. If you are american you more then likely only need en_US.UTF8.

Edit the /etc/locale.gen file and uncomment en_US.UTF8.

Comment out any others, unless of course you need them to be able to read.

Then run: sudo locale-gen

gnome-terminal should start then. If not install xterm and run gnome-terminal from it to see what is going on:

  • pacman -S xterm

  • Try CtrlaltF2, or exit X.

  • Then hit CtrlaltF1 to get back to X.

  • Hit AltF2 and type xterm

  • In the xterm window type gnome-terminal

4

Unless you really care about GNOME terminal, the best way is probably to install a different terminal emulator. Pick one you like.

Remember that CtrlAltF1 gets you to the GUI. Then, press CtrlAltF2 to go to a TTY. Log in, and search the repositories for the terminal you chose. I chose Guake:

pacman -Ss guake

It should come up with something. For me, it was:

community/guake 0.4.4-3
    Drop-down terminal for GNOME

Then, take the name and install that package:

pacman -S guake

You should then be able to launch the application by switching back to GNOME, pressing Super (the Windows key) and typing the name of the terminal.

2

This worked for me

in your ~/.xinitrc replace

exec gnome-session

with

exec dbus-launch --exit-with-session gnome-session 

Source: https://bbs.archlinux.org/viewtopic.php?id=203918

  • THANK YOU SO MUCH FOR THIS ANSWER! I've been fighting this issue for the last week. Nothing worked, but this started it up right away. – Zulfe Jun 3 '16 at 15:49
  • This is deprecated now and should be considered an ugly, and unneccesary, hack. – jasonwryan Nov 20 '16 at 18:05
2

I just meet the same problem here. I googled a lot, and I found a solution. If u can use Alt+F2(maybe laptop +Fn) , u can do:

1.login as root (use sudo 'ur pwd')

  1. $locale-gen "en_US.UTF-8"

then u should could open terminal succesfully.

  • This adds nothing to the existing answers... – jasonwryan Nov 20 '16 at 18:06
0

I had the same issue and found the solution :

  1. Copy the file /etc/X11/xinit/xinitrc to your ~/.xinitrc
  2. Add just after the line "#start some nice programs" : exec gnome-session
  3. logout and restart startx
0

I just fought with this issue for an hour. It turned out that my problem was that LC_COLLATE was set to "" (it had an extra space) instead of "C" in /etc/locale.conf.

protected by jasonwryan Nov 20 '16 at 18:06

Thank you for your interest in this question. Because it has attracted low-quality or spam answers that had to be removed, posting an answer now requires 10 reputation on this site (the association bonus does not count).

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.