I use sudo in many systems, but I have one of them that makes me type my password each time I run sudo. All the others remember it for a while. This is debian 7.4 wheezy and sudo 1.8.5

I found this : https://apple.stackexchange.com/questions/10139/how-do-i-increase-sudo-password-remember-timeout

and that: https://stackoverflow.com/questions/715908/how-do-you-make-sudo-save-the-password

so I checked the dir /var/lib/sudo. I removed my old user dir and restarted sudo. I made sure when I type sudo a file is created there.

I also changed the timestamp in /etc/sudoers, I tried with -1, and 5, with no luck.

Defaults        timestamp_timeout=5

I also issued a tail -f /var/log/auth and /var/log/syslog to see if anything went wrong but nothing is written there when I run sudo.

So I added a new file /etc/sudo.conf with this line:

Debug sudo /var/log/sudo_debug all@info

Now I see something in that file each time I run sudo but no error messages I can see. It looks like everything works fine.

Any hints ? thank you very much.

  • You have to describe your usage of sudo thoroughly. Also similar sudo questions appear repeatedly on stack exchange, so it's possible you would be much quicker with searching for them. Commented Apr 27, 2014 at 8:32
  • Did you try adding Defaults timestamp_timeout=5 to /etc/sudoers where it belongs?
    – terdon
    Commented Apr 27, 2014 at 9:52
  • I am working daily on the same system you described. A few days ago was thinking that sudo was acting differently the on previous Debian version, but then I realized that I was using sudo on many different xterms. Are you having the problem when running two next commands in the same terminal window?
    – eppesuig
    Commented Apr 27, 2014 at 11:43
  • My usage of sudo: in the same terminal I type: sudo ls ; sudo ls. I have to type my password twice. In other systems sudo remembers it for a while. I have been searching stackexchange and I tried what I learnt about sudo, but it didn't work. Commented Apr 27, 2014 at 16:34
  • 1
    Give us the output of your sudo policy file: sudo cat /etc/sudoers
    – hennr
    Commented Jun 30, 2014 at 9:38

1 Answer 1


Did you try purging sudo and then installing it again. Also there doesn't seem to be sudo 1.85 but rather 1.85p2-1 according to tracker.debian.org and in the changelog there wasn't just sudo 1.85.

Sometimes purging the package and then installing it again might do the trick.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .