4

I'm having issues with my Belkin N-300 USB wifi adapter. I can connect fine, but about a week ago the connection started getting very slow and regularly drops. Bringing the interface down and back up sometimes work and rebooting usually does. I've tried upgrading the kernel, but to no effect.

My signal quality is not that good, so I'm thinking part of the problem might be corruption caused by my high bitrate. According to iwlist, the current bitrate is not supported:

wlp2s0u2  4 available bit-rates :
          1 Mb/s
          2 Mb/s
          5.5 Mb/s
          11 Mb/s

          Current Bit Rate:150 Mb/s

I've tried changing it using iwconfig, specifically:

sudo iwconfig wlp2s0u2 rate 11M

which exits without error but does not actually change the bitrate. I've also tried with iw:

sudo iw dev wlp2s0u2 set bitrates legacy-2.4 11

but this returns the error command failed: No such device (-19), and similarly any iw command referencing wlp2s0u2 fails.

Relevant output of iwconfig:

wlp2s0u2  IEEE 802.11bgn  ESSID:redacted  Nickname:"rtl_wifi"
          Mode:Managed  Frequency:2.462 GHz  Access Point: 5C:96:9D:65:40:A3   
          Bit Rate:150 Mb/s   Sensitivity:0/0  
          Retry:off   RTS thr:off   Fragment thr:off
          Power Management:off
          Link Quality=99/100  Signal level=61/100  Noise level=0/100
          Rx invalid nwid:0  Rx invalid crypt:0  Rx invalid frag:0
          Tx excessive retries:0  Invalid misc:0   Missed beacon:0

I'm running Arch Linux with kernel 3.14.1-1.

  • This is a realtek rebranding USB. Bugs... – Rui F Ribeiro Apr 30 '17 at 20:18
0

This is a bit late, but as far as I understand, you need to turn wifi off before doing it, and on again afterwards.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.