2

I have Ubuntu 14.04 and Debian-7.4-Standard on my Acer Aspire One laptop.

I have Standard Debian OS which is command-line only. In the Debian OS I am not able to connect to the web through my wi-fi. I am missing the needed drivers.

So far I have downloaded firmware-nonfree_0.36+wheezy.1.tar.gz in my Ubuntu OS and placed it into my home directory in my Debian OS. But now what? Any ideas on how I can install my needed driver from there?


Update:

I managed to make some ground. What I did was to download from my Ubuntu system the firmware-linux-nonfree_0.36+wheezy.1_all.deb file and placed it into my home directory in my Debian system. Then I booted into my Debian OS and from my home directory as a superuser I ran the command

dpkg -i firmware-linux-nonfree_0.36+wheezy.1_all.deb

and then rebooted the system. Now my display looks much better, but I still am unable to connect the system to the web. As a result I am still unable to use apt-get update. At least the firmware problem is now solved.

2
  • tar xzfv firmware-nonfree_0.36+wheezy.1.tar.gz will unzip it. Maybe it contains an install guide? – Philipp Claßen Apr 26 '14 at 23:49
  • 1
    If your network driver is not working, ask a separate question about that. If this question was resolved, you can add an answer yourself and accept it. This helps people know the question was taken care of. – Faheem Mitha Apr 27 '14 at 3:54
2

What finally worked for me in installing the non-free firmware was to first download firmware-linux-nonfree_0.36+wheezy.1_all.deb to a directory in my home directory. Then from the directory with that file I ran the command

dpkg -i firmware-linux-nonfree_0.36+wheezy.1_all.deb

As far as I can see this has added all the missing drivers that I needed for my Acer laptop.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.