From what I read, wired internet should work out of the box during the Arch installation. However, I'm having difficulties. The dhcpcd service is running, but it says:

# systemctl status dhcpcd.service
  ... systemd[1]: Started dhcpcd on all interfaces
  ... dhcpcd[757]: enp5s0: waiting for carrier

The enp5s0 interface is down:

# ip addr
1: lo: <LOOPBACK,UP,LOWER_UP> mtu 65536 qdisc noqueue state UNKNOWN group default
    link/loopback 00:00:00:00:00:00 brd 00:00:00:00:00:00
    inet scope host lo
       valid_lft forever preferred_lft forever
    inet6 ::1/128 scope host
       valid_lft forever preferred_lft forever
2: enp5s0: <NO-CARRIER,BROADCAST,MULTICAST,UP> mtu 1500 qdisc pfifo_fast state DOWN group default qlen 1000
    link/ether e4:8d:04:ed:72:ce brd ff:ff:ff:ff:ff:ff

I tried to enable it but without any luck:

# ip link set enp5s0 up

There is no error or any other output, but the ip addr status is unchanged. enp5s0 is still down.

# lspci -v
 05:00.0 Ethernet controller Realtek Semiconductor Co., Ltd. RTL8111/8168/8411 PCI Express Gigabit Ethernet Controller (rev 03)
 Kernel driver in use: r8169
 Kernel modules: r8169

# mesg | grep r8169
r8169 Gigabit Ethernet driver 2.3LK-NAPI loaded
r8169 0000:05:00.0: irq 45 for MSI/MSI-X
r8169 0000:05:00.0: eth0: RTL8168d/8111d at ...
r8169 0000:05:00.0: eth0: jumbo features [frames: 9200 bytes, tx checksumming: ko]
r8169 0000:05:00.0: enp5s0: link down

Maybe it has to do with systemd renaming of eth0 (here to enp5s0)?

I'm stuck. Is there a way to find out what ip link set enp5s0 up does? As there is no error, I would assume that afterwards enp5s0 should be up.

UPDATE: Seems to be related to this problem Archlinux 2014.04 64bit and connectivity problem during instalation. I still haven't solved the problem, but I discovered that the wired LAN connection to my Fritzbox router is now broken on my machine. Beside with Arch Linux, it also stopped to work with my existing Windows installation on the same machine (though it worked fine, some hours ago).

If I plug the wired connection to another Ubuntu laptop, LAN works. I think, it has to do something with the router. Deleting the fixed IP assignment as in the other question, did not solve the issue, however.


1 Answer 1


Strange, it really has to do with the FritzBox Router, as described in the answer of this question:

Archlinux 2014.04 64bit and connectivity problem during instalation

Somehow Arch dhcp version confused the FritzBox router. As in the cited question, I also configured the router to always assign the same IP address to my MAC address.

As recommended in the cited answer, I deleted the IP assignment, but it did not work immediately. I remember that I readded the MAC address, but more likely, it worked after I powered down my computer (not only rebooting). When I switched it on again, the LAN connection light were immediately visible on the router. Afterwards, both Windows and an Archbang Live CD were able to connect.

Now, as the option to assign the same IP for the MAC address is disabled in the router, the Arch Linux installation also connects to the internet out of the box.

(My FritzBox is model 7112 with the lastest firmware updates: 87.04.88. I was using the current Arch CD archlinux-2014.04.01-dual.iso on an x86_64 machine. The dhcpcd version is 6.3.2-1.)


Not the answer you're looking for? Browse other questions tagged .