I have tried to mount an external USB 3.0 hdd on my debian virtual machine (I'm using VirtualBox). I have tried to mount it using mount /dev/sdb1/ /media/vol1/ but I get the following error:

mount: can't find /dev/sdb1 in /etc/fstab of /etc/mtab

I have tried to use fdisk -l, the error I get is the following:

    WARNING: GPT (GUID Partition Table) detected on '/dev/sdb'! The util fdisk doesn't support GPT. Use GNU Parted.

Disk /dev/sdb: 1000.2 GB, 1000170586112 bytes
255 heads, 63 sectors/track, 121597 cylinders, total 1953458176 sectors
Units = sectors of 1 * 512 = 512 bytes
Sector size (logical/physical): 512 bytes / 512 bytes
I/O size (minimum/optimal): 512 bytes / 512 bytes
Disk identifier: 0x00000000

   Device Boot      Start         End      Blocks   Id  System
/dev/sdb1               1  1953458175   976729087+  ee  GPT

This is the result of parted -l:

Model: WD My Passport 0748 (scsi)
Disk /dev/sdb: 1000GB
Sector size (logical/physical): 512B/512B
Partition Table: gpt

Number  Start   End     Size    File system  Name                   Flags
 1      20,5kB  210MB   210MB   fat32        EFI System Partition   boot
 2      210MB   1000GB  1000GB  hfsx         Apple_HFSX_Untitled_2

How can I mount the hdd and read its content?

  • 1
    Please include the command you ran which gives the error. The output you show and the error you quote are from fdisk which has nothing to do with mounting.
    – terdon
    Apr 26 '14 at 10:21
  • Thank you for the suggestion. I improved my question, I hope that now it il clearer.
    – giovi321
    Apr 27 '14 at 16:26
  • Please follow the suggestion in your error message. Edit your question and add the output of sudo parted -l. Don't take a screenshot, just copy paste it into your question using the formatting tools available. Also, check man mount. The format of the mount command is mount partition mount_point, so you would need something like mount /dev/sdb1 /media/disk.
    – terdon
    Apr 27 '14 at 16:33
  • Thank you for the suggestions. I did use mount correctly, it was a typo in the question. I also put the results of the commands formatted correctly instead of the previous picture.
    – giovi321
    Apr 28 '14 at 19:07
  • 2
    I think the reason for the error message is quite simple: you need to drop the trailing slash from /dev/sdb1/ and just use /dev/sdb1. With the trailing slash mount will treat /dev/sdb1 as a directory and search for a device to mount there in /etc/fstab.
    – Graeme
    May 1 '14 at 18:32

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.