4

I'm trying to change it to Latin America language, however in the System Settings->Hardaware->input devices-layout tab nothing seem to works correctly (even if I add any layout)

enter image description here

Also I can type for accents but in a weird manner. I have used the answer as discussed here. I have used that answer (the method # 1 and # 2) system-config-keyboard selecting Latin America, and works perfect but when I restart the computer changes are not saved, and need to do that again.

enter image description here

What can I do then?

3

Are you trying as a root user? Open the command prompt and type,

system-config-language

After selecting the language you want, the next time you boot, the settings will take place. To verify if the language change took place, run the below command.

locale

However, since you want to change the keyboard layout, you can use the command,

system-config-keyboard

After changing the keyboard configuration, you can verify if the change took place by using the below command.

setxkbmap -print | grep xkb_symbols | awk '{print $4}' | awk -F"+" '{print $2}'
0

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.