I am running Ubuntu 12.04.4 with network interface:

       description: Wireless interface
       product: Centrino Advanced-N 6235
       vendor: Intel Corporation
       physical id: 0
       bus info: pci@0000:01:00.0
       logical name: wlan0
       version: 24
       serial: c8:f7:33:8f:d3:9c
       width: 64 bits
       clock: 33MHz
       capabilities: pm msi pciexpress bus_master cap_list ethernet physical wireless
       configuration: broadcast=yes driver=iwlwifi driverversion=3.5.0-48-generic firmware= ip= latency=0 link=yes multicast=yes wireless=IEEE 802.11abgn
       resources: irq:43 memory:d0400000-d0401fff

I have been trying to set up an Ad-hoc network on my laptop for some time now. I have already established that it works pretty much always at home, but not at work (I figure because there are more networks here).

Today I figured I'd replace the existing driver with one from the manufacturer website, even though they seemed to be exactly the same. (iwlwifi-6000g2b-6.ucode, version Unfortunately I didn't back up the old one.

With the 'new' driver I was suddenly able to set up a Ad-hoc network again, using either NetworkManager (

* ipv6 ignore
* 2.4 GHz (default)
* ipv4 manual    
* WEP 40/128 bit key (Hex or ASCII)
* MTU automatic

or commandline with iwconfig commands (With NetworkManager shutdown).

iwconfig wlan0 key 1234567890
iwconfig wlan0 mode ad-hoc
iwconfig wlan0 essid MyAdhoc
ifconfig wlan0 netmask

But here's the kicker, it fails to work after the NetworkManager establishes another connection (Infrastructure, WPA2).

When it fails using the NetworkManager these lines repeatedly show up in /var/log/kern.log:

Apr 23 11:01:57 *** kernel: [ 2424.593393] iwlwifi 0000:01:00.0: L1 Enabled; Disabling L0S
Apr 23 11:01:57 *** kernel: [ 2424.600237] iwlwifi 0000:01:00.0: Radio type=0x2-0x1-0x0
Apr 23 11:01:57 *** kernel: [ 2424.720967] IPv6: ADDRCONF(NETDEV_UP): wlan0: link is not ready

and /var/log/syslog where I find the problem is with the wpa_supplicant:

Apr 29 17:13:39 *** wpa_supplicant[8406]: nl80211: Failed to set interface into IBSS mode
Apr 29 17:13:39 *** wpa_supplicant[8406]: Association request to the driver failed

Trying manually then results in (response to iwconfig wlan0 mode ad-hoc):

Error for wireless request "Set Mode" (8B06) :
SET failed on device wlan0 ; Operation not supported.

I have tried disabling ipv6 as suggested here among others to no avail.

Then I tried editing the GRUB file as suggested here, which means booting with ipv6.disable=1. After reboot, it does eliminate the third line but it does not result in an Adhoc network.

If I want to establish a new Ad-hoc network to reset the iwlwifi mod (And if I use the NetworkManager I have to be fast enough to ensure that it doesn't start on another network first).

sudo rmmod iwlwifi
sudo modprobe iwlwifi

Does anyone have an idea what the problem could be and how to resolve it?

  • I see you have two related questions, here: unix.stackexchange.com/questions/126099/… – Pavel Šimerda Apr 26 '14 at 17:35
  • Sorry for possibly stating the obvious but it looks like your problem is somehow related to the iwlwifi driver. The good thing is that iwlwifi is rather common among linux users. You might want to create a more precise description of your tests, or even a proper reproducer that would allow anyone to easily spot the bug you're hitting. – Pavel Šimerda Apr 26 '14 at 17:38
  • I incorporated the related question. I think it should be possible to reproduce the problem with the available information. If not, please let me know what I can do to help. – Oxidator Apr 26 '14 at 21:18
  • Could you possibly check it with a recent Fedora live CD/DVD/USB? If it works, you can check differences between those systems. When you're done, you might want to visit #nm on IRC freenode. Wifi problems reproduced with the current Fedora might be of interest to dcbw, wifi problems specific to Ubuntu/Debian releases might be of interest to cyphermoce, mbiebl or tore. If you're successful, don't forget to add the answer to stack exchange as well. – Pavel Šimerda Apr 27 '14 at 8:29

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.