0

This question already has an answer here:

My host OS is Gentoo, guest OS - Fedora. I have a web server on Fedora on port 8686 and it works perfectly on guest OS, but I can't access it on my host OS. I tried to use bridged network (then I got 2 different IPs to my guest and host machines from router) and NAT (then I forward port 8686). Nothing helped, but SSH works nicely when using both NAT and bridge (even if using the same port). How to solve this issue?

marked as duplicate by slm, jasonwryan, Anthon, Zelda, Braiam Apr 24 '14 at 15:28

This question has been asked before and already has an answer. If those answers do not fully address your question, please ask a new question.

  • You should add the guest OS entry in \etc\hosts file of the host OS. – Ramesh Apr 23 '14 at 17:38
  • Did you check iptables on the guest OS using iptables -nvL? – mtak Apr 23 '14 at 18:59
  • >[...] but I can't access it on my host OS. – Chipster Apr 23 '14 at 19:10
  • Take a look at this Q if you're attempting to use NAT: unix.stackexchange.com/questions/12885/… – slm Apr 24 '14 at 0:16
  • @mtak, I disabled iptables on the guest OS – milos Apr 24 '14 at 14:43
0

If ssh works nicely in both NAT and bridge and on the same port as web-server, then problem is in your web-server configuration.
Check what ip address your web-server binds to. You can check it with netstat utility (you must run it with root privileges):
netstat -nltp

Not the answer you're looking for? Browse other questions tagged or ask your own question.