6

I've just upgraded my distribution from 13.10 to 14.04, which seems to have broken global keyboard shortcuts.

They are still present in the "Keyboard settings" as before. Although media keys are affected, so are other global shortcuts like Ctrl+Alt+T for Terminal. Other keyboard shortcuts work at an application level still, however.

I am also currently using Gnome Shell as my desktop environment, although the Alt+F2 shortcut for shell commands still seems to work.

Does anyone know of how this could have been caused?

4

I just ran into this issue on my laptop. I'm not certain why, since my install has been working fine for a few months, but just today all the shortcuts in the "Keyboard settings" ceased to work. As is hinted at briefly at the bottom of this thread, there seems to be a bad gnome configuration. I tried removing my ~/.gconf folder (after making a backup first!) and logging out/in, and that fixed my problem. The full steps to fix were:

  1. Open up your home folder by pressing the Windows (or meta) key or by clicking on the first icon in the doc, then typing Files and opening the Files application.
  2. Show hidden files and folders by pressing Ctrl+H.
  3. Find the .gconf folder and rename it to .gconfg.bak.
  4. Hide hidden files and folders again by pressing Ctrl+H.
  5. Log out of your account and back in. while some of your settings may be back to default, your shortcuts should work again.
  • Thanks for the help, but still nothing. What exactly in the .gconf folder am I looking to reset? – bak202 Jul 23 '14 at 6:24
  • You just need to remove (or rename) the entire folder, then log out and log back in. – FuegoFro Jul 23 '14 at 17:27
  • Yeah I did that, but it didn't work. I think my particular issue could have been something else over-riding gsettings. I've since reinstalled my entire system and haven't run into the problem since. – bak202 Jul 24 '14 at 11:06
  • That's fair. It seems like there were a couple of different issues here which manifested themselves with the same symptoms, so it's likely that what worked for me might not work for you. Glad you got it fixed though! – FuegoFro Jul 24 '14 at 17:03
  • Works for me - Ubuntu Gnome 14.10 – mac Dec 2 '14 at 7:28
1

This has cropped up numerous times in Ubuntu's Launchpad, but more recently, someone has bothered to post a fix to this -- which doesn't include completely overwriting your Gconf.

https://bugs.launchpad.net/ubuntu/+source/unity-control-center/+bug/1302885/comments/4

In a nutshell, running this at the prompt:

gsettings reset org.gnome.settings-daemon.plugins.media-keys volume-up

This will reset the Volume Up key to 'XF86AudioRaiseVolume' (i.e. your volume up key)

If you find this happens often, get the names of the keys from dconf and have this run on startup.

0

In my case the gnome-settings-daemon process was hang:

 0 D alex   3798  3587  0  80   0 - 472136 rpc_wa Apr18 tty2    00:00:17 /usr/libexec/gnome-settings-daemon

I just killed it and it reloads automatically. After that everything is working properly.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.