I tried to slow down my CPU with powernowd and cpufreq-selector. I hoped that with lower frequency it will be less hot and I won't hear my fan every time I will run internet radio. I used the following commands

sudo cpufreq-selector -f 800000


sudo powernowd -m 0 -l 40 -u 60

but this wasn't sufficient for more quiet laptop.

My CPU is

Intel(R) Pentium(R) M processor 1.60GHz

Could you advise me on how to make it run cooler / quieter?

I solved it yesterday with sudo cpufreq-selector -g powersave


The very important thing is to lower down the cpu clock first.

The second important part is to verify there is no physical cooling problem (like dust on the fans, cat or dog hairs in the heatsink ect)

On most computers, the fan speed is directly operated by the bios or the os automatically.

The cleaning/lowering cpu speed process should let the cooling performs better, and, if the T° goes down, so the speed of the fans too.

If it's not, I advise you to look into fancontrol It's a little application that uses lm-sensors and pwm-config (pwm is the thing commonly used to drive the fan rotation speed from the computer, see: https://secure.wikimedia.org/wikipedia/en/wiki/Fan_control#Pulse-width_modulation) to regulate automatically the fan speed according to the CPU temperature

Here is little documentation about it: http://www.lm-sensors.org/wiki/man/fancontrol

I assure you that is more easier than it looks, but primary you need to install and configure sensors to your computer. It has a little easy-config script to help you to detect & configure your sensors and stuff, called sensors-detect in most distros. I advise you to google about it, including your distro name and your laptop brand/model to find the best settings

After that, just run pwmconfig as root. It detects driveable fans and temperature sensors, and asks you Min/Max Temps for cpu and Min/Max fan speed you want.

| improve this answer | |
  • 1
    My laptop uses ACPI and not support lm-sensors. If you know how to set it with ACPI, please add it to your answer. I solved it yesterday with sudo cpufreq-selector -g powersave – xralf May 5 '11 at 5:12

Another solution is to control the fan with the embedded controller. My box uses ACPI and it was broken by design but the fan was controlled by the BIOS. I managed to control the embedded controller and override the fan manual mode and the fan speed by the embedded controller. In fact I copy & paste a kernel module, see my answer here How do I start the fan manually in Linux?.

| improve this answer | |
  • For access to your EC, check aceracpi.googlecode.com/svn/trunk/acer_ec/acer_ec.pl – Lekensteyn Jan 26 '12 at 11:24
  • @Lekensteyn: I use exactly this script but I've other register for the fan control. It's important to find them first. It's not easy and you can cook your cpu easily. I recommend to check if your cpu and motherboard suppport THERMAL SHUTDOWN when the temperature is too hot. – Gigamegs Jan 27 '12 at 16:52

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.