1

I followed the Debian Instructions for upgrading from Squeeze to Wheezy in Debian. I audited my packages, updated my /etc/apt/sources.list file to get Wheezy sources, I ran apt-get update and apt-get upgrade, and upgraded many packages. Everything was still working.

Now, if I do anything with apt-get that involves installing or updating, I get the following error:

W: Failed to fetch http://ftp.ca.debian.org/debian/dists/wheezy/main/binary-amd64/Packages Something wicked happened resolving 'ftp.ca.debian.org:http' (-11 - System error) (the URL may be different, but the error messages are all the same).

Many threads online mention to try to ping those addresses. My ISP here blocks ping, but I can do an nslookup to the domain names, and get the right IP address. I can also use wget to download webpages by name (i.e. wget www.google.com works, and gives me the index.html file). So I know name resolution is NOT an issue.

I checked the dpkg log, but it doesn't seem too helpful:

/var/log# tail dpkg.log
2014-04-21 09:55:35 status installed dictionaries-common:all 1.12.11
2014-04-21 09:55:35 trigproc menu:amd64 2.1.46 <none>
2014-04-21 09:55:35 status half-configured menu:amd64 2.1.46
2014-04-21 09:55:35 status installed menu:amd64 2.1.46
2014-04-21 09:55:35 trigproc sgml-base:all 1.26+nmu4 <none>
2014-04-21 09:55:35 status half-configured sgml-base:all 1.26+nmu4
2014-04-21 09:55:35 status installed xml-core:all 0.13+nmu2
2014-04-21 09:55:35 status installed sgml-base:all 1.26+nmu4
2014-04-21 11:23:38 startup packages purge
2014-04-21 11:39:37 startup packages purge

(This post is being made about 5 hours later. Apt and Aptitude are not writing here). The files in /var/log/apt haven't been written to since 09:55am today, so nothing is getting written there either. The / partition has 83 GB free (I didn't build this server, my predecessor did).

Aptitude loads, but won't download anything. In it, if I hit the u key to bring up the Update screen, I'm greeted with all the same error messages, in red, and a dialog reading Downloaded 0 B in 0s (0 B/s). Some files were not downloaded successfully..

I have tried restarting, and nothing seems to change. My current services are still running OK on it (i.e. Samba, Apache2). What can I look into to try to figure this out?

2

To prevent nsswitch from conflicting, add

hosts: wins files dns

to your /etc/nsswitch.conf

As seen here.

  • Actually, I removed wins completely, and it started working... Maybe I'll try putting wins at the end (since it's my Samba server) – Canadian Luke Apr 22 '14 at 2:44

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.