3

I have a laptop running Debian Jessie with only the Linux console (X server not installed). On this laptop caps lock doesn't take effect on the special Danish characters æøå (I just get æøå instead of ÆØÅ).

To troubleshoot I've done some testing on my other computer which runs Debian Wheezy. On this computer, when I log into the Linux console, caps lock does indeed work on those characters.

After discovering this, I've made sure to have identical settings for keyboard on both machines:

dpkg-reconfigure keyboard-configuration: Generic 105-key (Intl) PC, Danish
dpkg-reconfigure console-data: Do not touch keymap
dpkg-reconfigure console-setup: UTF8, # Latin1 and Latin5 - western Europe and Turkic languages

With the above settings the problem (which is absent on the Wheezy computer) persist on the Jessie computer. It should be noted that after running dpkg-reconfigure keyboard-setup on the Jessie machine I get this error:

update-rc.d: warning: start and stop actions are no longer supported; falling back to defaults

Does this mean that the changes havn't taken effect?

It should also be noted that I managed to reproduce the problem on the Wheezy machine by running dpkg-reconfigure console-data and choosing these options (instead of Do not touch keymap):

Select keyboard from list, qwerty, Danish, deadkeys

This gives me the output:

Looking for keymap to install:
dk-latin1

After that, caps lock didn't take effect on the Danish characters on the Wheezy machine either (luckily this changed back after reboot). This could indicate the Jessie machine runs with the above settings and that's what's causing the problem but when I run dpkg-reconfigure console-data and chose the same settings as above on my Jessie machine I get another problem (until reboot): my tmux prefix which I've mapped to C-\ isn't recognized. This probably mean that the settings effectuated by running dpkg-reconfigure console-data aren't the default settings on my Jessie machine.

What is causing the issue? Can it be fixed or is there a workaround to rebind æøå to ÆØÅ when caps lock is on?

1

I've filed a report and indeed it is confirmed as a bug.

Found this workaround:

On the computer running Wheezy:

 $ sudo dumpkeys -l > mykeys.txt

On the computer running Jessie, I've added this to /etc/rc.local:

loadkeys /path/to/mykeys.txt

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.