1

I'm using a USB drive in my Raspberry to store my website. Now I want also save my videos made with motion.

I wasn't able to save in a folder different from /tmp/motion so googling I found I had to give permission to the folder where I wanted to use.

$ sudo chmod 777 /path/

I tried in the user directory /home/pi and it worked, then I tried the same on my USB drive.

  • Filesystem /dev/sda1
  • Size 3.6G
  • Used 1.3M
  • Avail 3.6G
  • Use% 1%
  • Mounted On /home/pi/usbdrv

$ sudo chmod 777 /home/pi/usbdrv

But didn't work.


Some info:

So

$ sudo service motion start

motion start working, I can see images via browser, but as soon as the webcam try to save a file (e.g. a photo) the thread of the webcam crash. Trying stop motion in the same way

$ sudo service motion stop

I get

[....] Stopping motion detection demon: motionNo /usr/bin/motion found running; none killed.
. ok

else if there are more webcams service still run until when all of them try to save datas.


Another test: While if I try, always from terminal:

$ sudo motion

I get

[0] Processing thread 0 - config file /etc/motion/motion.conf
[0] Processing config file /etc/motion/thread1.conf
[0] Processing config file /etc/motion/thread2.conf
[0] Motion 3.2.12 Started
[0] Exit motion, cannot create process id file (pid file) /var/run/motion/motion.pid: No such file or directory
[0] Motion going to daemon mode
$

PS: I have two thread file, because I have two webcams


My USB:

/dev/sda1 on /home/pi/usbdrv type vfat (rw,nosuid,relatime,sync,uid=1000,gid=1000,fmask=0022,codepage=437,iocharset=ascii,shortname=mixed,errors,remount-ro)

More info: http://www.raspberrypi.org/forums/viewtopic.php?f=28&t=75136

  • Can you fix the first chmod 777 command? That does nothing w/o a directory or file to operate against. – slm Apr 19 '14 at 22:15
  • Yes I know, but I want say that chmod 777 is the command I found which give permissions – Mitro Apr 19 '14 at 22:22
  • motion use by default /tmp/motion, I'm able to save videos and images in user directory and other directories, but not in my usb drive, also after that command – Mitro Apr 19 '14 at 22:23
  • What's the distro you're using? – slm Apr 19 '14 at 23:09
  • 7
    Tip: if some tutorial tells you to do chmod 777, it means the author of the tutorial has no idea what they're doing and is flailing blindly in the dark. Close the tutorial and don't follow any of its recommendations. Now, explain to us your real problem — what did you change in the configuration of Motion? Or did it always crash before you started messing about with permissions? What are you doing to “save” your videos: are you copying some files? Where and with what tool? or using the “Save” menu in some software? – Gilles 'SO- stop being evil' Apr 19 '14 at 23:12

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.