4

I have just installed Debian Wheezy for the first time and have had mixed success getting my system up and running. Currently my main issue is that I am unable to extend my desktop to my second screen.

I have an ATI radeon HD 7700 series graphics card connected to 2 displays. Running lspci results in this line, among others:

04:00.0 VGA compatible controller: Advanced Micro Devices [AMD] nee ATI Cape Verde [Radeon HD 7700 Series]

Currently, both are cloned. I initially tried to follow the instructions for installing proprietary ATI drivers, which resulted in the 2nd display being detected but I was unable to extend the desktop rather than clone it (something about my virtual screen not being big enough).

I gathered that support might be better for the free version so I followed these instructions for removing said drivers, followed by these instructions to install the free ones.

As per the troubleshooting step in that page I ran this command:

dmesg | grep -E 'drm|radeon' | grep -iE 'firmware|microcode'

which produced this output:

[    4.925773] [drm] Loading VERDE Microcode  
[    4.990158] platform radeon_cp.0: firmware: agent loaded radeon/VERDE_pfp.bin into memory 
[    5.152647] platform radeon_cp.0: firmware: agent loaded radeon/VERDE_me.bin into memory 
[    5.236165] platform radeon_cp.0: firmware: agent loaded radeon/VERDE_ce.bin into memory [    5.260082] platform radeon_cp.0: firmware: agent loaded radeon/VERDE_rlc.bin into memory 
[    5.376566] platform radeon_cp.0: firmware: agent loaded radeon/VERDE_mc.bin into memory

That's different to the outputs on that page but then they don't really give anymore information so I just assumed everything had worked.

Anywho, now when I go to System Tools -> Preferences -> System Settings -> Display I just see a single display called Unknown, which clones across both of my monitors.

running xrandr -q produces this output:

xrandr: Failed to get size of gamma for output default Screen 0: minimum 1680 x 1050, current 1680 x 1050, maximum 1680 x 1050 default connected 1680x1050+0+0 0mm x 0mm 1680x1050 0.0*

FYI 1680x1050 is the native resolution of both monitors. I do not have a /etc/X11/xorg.conf file, and my /etc/X11/xorg.conf.d/ directory seems to be empty.

This is my first time running a linux system so I'm totally confused and would appreciate kind words and idiot-proof guidance.

  • Could you include the full output of xrandr -q with the screen connected please? – terdon Apr 19 '14 at 12:56
  • @terdo that is the full output. – quant Apr 19 '14 at 12:58
  • 1
    Try the A from this AU Q&A: askubuntu.com/questions/71457/… – slm Apr 19 '14 at 13:15
  • @slm I reinstalled the proprietary drivers (wiki.debian.org/ATIProprietary) and restarted. Running gksudo amdcccle as per that answer produces this output: (gksudo:4955): GConf-WARNING **: Client failed to connect to the D-BUS daemon: Did not receive a reply. Possible causes include: the remote application did not send a reply, the message bus security policy blocked the reply, the reply timeout expired, or the network connection was broken. GConf Error: No D-BUS daemon running and nothing opens.. – quant Apr 19 '14 at 13:36
  • @ArmanSchwarz - seems like DBUS isn't running but that doesn't make any sense to me. I've posted this to 2 of our resident Debian/Ubuntu/Mint guys to see if they have any thoughts in the chatroom: chat.stackexchange.com/transcript/message/15044646#15044646 – slm Apr 19 '14 at 13:43
2

I found this answer on AU in a Q&A titled: How can I set up dual monitor display with ATI driver?.

excerpt

  1. Open a terminal and type:

      $ gksudo gedit /etc/X11/xorg.conf
    
  2. In the sub-section "display" add this code or modify if already exist:

      virtual 2880 1024
    
  3. Where 2880 and 1024 are the value returned by the error: required virtual size does not fit available size: requested=(2880, 1024), minimum=(320, 200), maximum=(1600, 1600).

  4. Restart the computer.

  5. Then you will be able to extend your desktop without issue.

In the OP's configuration he opted to use this:

virtual 3360 1050

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.