6

I was using google chrome browser on Ubuntu 12.04 machine, recently I needed to switch to chromium-browser. I am using the version that is available on the Ubuntu software centre. The problem is that I can't make java applets to load any more.

Here is my situation --

  1. I am using vanilla jdk (jdk 1.7.0_51) from the oracle.
  2. Previously in chrome, I have created a symlink of libnpjp2.so to the /opt/google/chrome/plugins folder, java applets were working fine.
  3. After uninstalling chrome and installing chromium-browser, I made a symlink of libnpjp2.so to /usr/lib/chromium-browser/plugins folder, but java applets do not fire up any more (even from this site: http://www.java.com/en/download/installed.jsp)
  4. Even libnpjp2.so appears in about:plugins in chromium-browser and showing it's enabled.

What I have tried so far --

  1. After uninstalling chrome, the /opt/google/chrome was still there, I removed it
  2. Made the symlink as the point 3 above to /usr/lib/chromium-browser/plugins, but no luck.
  3. So I installed icedtea-7-plugins from the Ubuntu repo and made a symlink of IcedTeaPlugin.so to /usr/lib/chromium-browser/plugins, but no luck, so I removed it.
  4. Added the java applet test page to the exclusion list in the java control panel.
  5. Cleared temporary internet files from the java control panel.
  6. Did multiple cycles of "enable/disable" java plugins in chromium-browser.
  7. Firing up the chromium-browser with -enable-plugins switch did not work.

When I go to the java applet test page, what I can only see is a grey rectangle, nothing else. Please note, everything was working fine on chrome browser and also in firefox. Please also note I do not want to install openjdk stuffs.

any idea ?

5

As found at AskUbuntu:

Java (IcedTea) doesn't have a PPAPI plugin available, and so it's not usable in Chromium, since Chromium 34 in Trusty has switched to the Aura rendering framework and no longer allows NPAPI plugins. See also https://bugs.launchpad.net/ubuntu/+source/chromium-browser/+bug/1308783.

I guess it's a same with Oracle Java plugin. At least it works with Firefox so you can use FF until the PPAPI implementation is available.

2

Have you enabled the plugin in the about:plugins menu? To access this in your address bar type about:plugins.

                ss #1

Make sure that the plugin has been enabled.

Other things to try

  1. Look through the open issues of Chromium. Here's a list of the open issues with JDK referenced.
  2. Confirm that the plugin is enabled through JDK's ./ControlPanel dialog. Details here.
  3. Other things suggested in the KB Mozillazine topic regarding Java.
  4. Try downgrading to an older version of the JDK just to confirm that the issue isn't with 1.7.0_51.
  • thanks but I am afraid you did not go through my post, may be you thought TL;DR. Please see the point 4 in the first paragraph, and also see the point 6 in the second paragraph. – ramgorur Apr 18 '14 at 3:24
  • @ramgorur - see updates for other leads. – slm Apr 18 '14 at 15:49
0

Starting at Chrome 35, NPAPI plugins are no longer supported (that includes Java). It started with Linux, but apparently all other platforms will suffer that change eventually.

All you can do for now is:

  1. Use Firefox whenever you need Java.
  2. Hope Oracle releases a PPAPI version of its java plugin.
-1

Java Verify failure unable to Configure Java Control Panel does not open ( Fix : )

this is a regular ( windows 7 bug related ) problem after successful installation of Java ( jre ) and fresh installation of Windows7 64bit or 32bit on my laptop or desktop. what worked perfectly for me was setting COMPATIBILITYMODE=WINDOWSNT to make windows launch the JP2LAUNCHER.EXE and JAVAW.EXE files properly. jp2launcher.exe windowsNT compatibilty solves Java Verify failure problem at https://www.java.com/en/download/installed.jsp
javaw.exe windowsNT compatibilty solves unable to open or Configure Java Control Panel problem.

*  search for JAVAW.EXE   inside  c:\program files\java\....\bin   
      or  c:\program files(x86)\java\.....\bin\
*  right-click mouse on  JAVAW   application icon logo
*  click  PROPERTIES
*  click  COMPATIBILITY
*  tick the checkbox at COMPATIBILITY MODE
*  choose  WINDOWS NT service pack
*  click APPLY or click OK

Now, the Configure Java Control Panel will start opening and working.

*  search for JP2LAUNCHER.EXE   inside  c:\program files\java\....\bin   
      or  c:\program files(x86)\java\.....\bin\
*  right-click mouse on  JP2LAUNCHER
*  click  PROPERTIES
*  click  COMPATIBILITY
*  tick the checkbox at COMPATIBILITY MODE
*  choose  WINDOWS NT service pack
*  click APPLY or click OK

Now, the Verify Java will be successful at https://www.java.com/en/download/installed.jsp

if we find 2 or 3 versions of JP2LAUNCHER and JAVAW when we search, then we must repeat the above for all of them.

in the Configure Java Control Panel Advanced tab we can set "Do not check" certificate revocation and disable security verification. and in the Security tab we may Edit Site List... for the Exception Site List ( add URLs to unblock sites )

  • the question is on Ubuntu, your answer related only to windows. – Tejas Nov 19 '14 at 4:17

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.