2

On my ThinkPad x201, I've been having problems where the computer will shutdown once it has been suspended to RAM, so I disabled the auto-suspend when the lid is closed by editing /etc/systemd/logind.conf:

#HandleHibernateKey=hibernate
HandleLidSwitch=None
#PowerKeyIgnoreInhibited=no

This works fine, however, when running tlp, my computer starts to suspend again. I have looked through the arch wiki and the documentation, but still haven't found a flag that controls this.

Is there any way to control tlp's override of the auto-suspend feature when laptop lids are closed?

1

Turns out that it was tp_smapi's fault! I uninstalled it, and I can successfully suspend to RAM (even with TLP)

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.