4

2.6.32-71.el6.x86_64
RHEL 6

Please see at the end I am getting some issues due to dependency:

[root@xilinx Downloads]# yum install --skip-broken  glibc*
Loaded plugins: refresh-packagekit, rhnplugin
There was an error parsing the RHN proxy settings.
RHN support will be disabled.
Setting up Install Process
Examining glibc-2.12-7.2.x86_64.rpm: glibc-2.12-7.2.x86_64
Marking glibc-2.12-7.2.x86_64.rpm as an update to glibc-2.12-1.7.el6.x86_64
Marking glibc-2.12-7.2.x86_64.rpm as an update to glibc-2.12-1.7.el6.i686
Examining glibc-2.15-60.el6.x86_64.rpm: glibc-2.15-60.el6.x86_64
Marking glibc-2.15-60.el6.x86_64.rpm as an update to glibc-2.12-1.7.el6.x86_64
Marking glibc-2.15-60.el6.x86_64.rpm as an update to glibc-2.12-1.7.el6.i686
Examining glibc-common-2.12-7.2.x86_64.rpm: glibc-common-2.12-7.2.x86_64
Marking glibc-common-2.12-7.2.x86_64.rpm as an update to glibc-common-2.12-1.7.el6.x86_64
Examining glibc-common-2.15-60.el6.x86_64.rpm: glibc-common-2.15-60.el6.x86_64
Marking glibc-common-2.15-60.el6.x86_64.rpm as an update to glibc-common-2.12-1.7.el6.x86_64
Examining glibc-devel-2.12-7.2.x86_64.rpm: glibc-devel-2.12-7.2.x86_64
Marking glibc-devel-2.12-7.2.x86_64.rpm as an update to glibc-devel-2.12-1.7.el6.x86_64
Marking glibc-devel-2.12-7.2.x86_64.rpm as an update to glibc-devel-2.12-1.7.el6.i686
Examining glibc-devel-2.15-60.el6.x86_64.rpm: glibc-devel-2.15-60.el6.x86_64
Marking glibc-devel-2.15-60.el6.x86_64.rpm as an update to glibc-devel-2.12-1.7.el6.x86_64
Marking glibc-devel-2.15-60.el6.x86_64.rpm as an update to glibc-devel-2.12-1.7.el6.i686
Examining glibc-headers-2.15-60.el6.x86_64.rpm: glibc-headers-2.15-60.el6.x86_64
Marking glibc-headers-2.15-60.el6.x86_64.rpm as an update to glibc-headers-2.12-1.7.el6.x86_64
Examining glibc-static-2.12-7.2.x86_64.rpm: glibc-static-2.12-7.2.x86_64
Marking glibc-static-2.12-7.2.x86_64.rpm to be installed
Examining glibc-static-2.15-60.el6.x86_64.rpm: glibc-static-2.15-60.el6.x86_64
Marking glibc-static-2.15-60.el6.x86_64.rpm to be installed
Examining glibc-static-2.18-12.fc20.x86_64.rpm: glibc-static-2.18-12.fc20.x86_64
Marking glibc-static-2.18-12.fc20.x86_64.rpm to be installed
Resolving Dependencies
--> Running transaction check
---> Package glibc.x86_64 0:2.15-60.el6 set to be updated
--> Processing Dependency: glibc-common = 2.12-1.7.el6 for package: glibc-2.12-1.7.el6.i686
---> Package glibc-common.x86_64 0:2.15-60.el6 set to be updated
---> Package glibc-devel.x86_64 0:2.15-60.el6 set to be updated
--> Processing Dependency: glibc-headers = 2.12-1.7.el6 for package: glibc-devel-2.12-1.7.el6.i686
---> Package glibc-headers.x86_64 0:2.15-60.el6 set to be updated
---> Package glibc-static.x86_64 0:2.12-7.2 set to be updated
--> Processing Dependency: glibc-devel = 2.12-7.2 for package: glibc-static-2.12-7.2.x86_64
---> Package glibc-static.x86_64 0:2.15-60.el6 set to be updated
---> Package glibc-static.x86_64 0:2.18-12.fc20 set to be updated
--> Processing Dependency: glibc-devel = 2.18-12.fc20 for package: glibc-static-2.18-12.fc20.x86_64
--> Finished Dependency Resolution
--> Running transaction check
---> Package glibc.x86_64 0:2.15-60.el6 set to be updated
--> Processing Dependency: glibc-common = 2.15-60.el6 for package: glibc-2.15-60.el6.x86_64
---> Package glibc-devel.x86_64 0:2.15-60.el6 set to be updated
--> Processing Dependency: glibc-headers = 2.15-60.el6 for package: glibc-devel-2.15-60.el6.x86_64
---> Package glibc-static.x86_64 0:2.15-60.el6 set to be updated
--> Finished Dependency Resolution
--> Running transaction check
---> Package glibc-static.x86_64 0:2.15-60.el6 set to be updated
--> Processing Dependency: glibc-devel = 2.15-60.el6 for package: glibc-static-2.15-60.el6.x86_64
--> Finished Dependency Resolution

Packages skipped because of dependency problems:
    glibc-2.15-60.el6.x86_64 from /glibc-2.15-60.el6.x86_64
    glibc-common-2.15-60.el6.x86_64 from /glibc-common-2.15-60.el6.x86_64
    glibc-devel-2.15-60.el6.x86_64 from /glibc-devel-2.15-60.el6.x86_64
    glibc-headers-2.15-60.el6.x86_64 from /glibc-headers-2.15-60.el6.x86_64
    glibc-static-2.12-7.2.x86_64 from /glibc-static-2.12-7.2.x86_64
    glibc-static-2.15-60.el6.x86_64 from /glibc-static-2.15-60.el6.x86_64
    glibc-static-2.18-12.fc20.x86_64 from /glibc-static-2.18-12.fc20.x86_64

May be this the reason that some of my programs are not working. How do resolve this dependency problem ?

Update

[root@xilinx Downloads]# yum install   glibc*
Loaded plugins: refresh-packagekit, rhnplugin
There was an error parsing the RHN proxy settings.
RHN support will be disabled.
Setting up Install Process
Examining glibc-2.12-7.2.x86_64.rpm: glibc-2.12-7.2.x86_64
Marking glibc-2.12-7.2.x86_64.rpm as an update to glibc-2.12-1.7.el6.x86_64
Marking glibc-2.12-7.2.x86_64.rpm as an update to glibc-2.12-1.7.el6.i686
Examining glibc-2.15-60.el6.x86_64.rpm: glibc-2.15-60.el6.x86_64
Marking glibc-2.15-60.el6.x86_64.rpm as an update to glibc-2.12-1.7.el6.x86_64
Marking glibc-2.15-60.el6.x86_64.rpm as an update to glibc-2.12-1.7.el6.i686
Examining glibc-common-2.12-7.2.x86_64.rpm: glibc-common-2.12-7.2.x86_64
Marking glibc-common-2.12-7.2.x86_64.rpm as an update to glibc-common-2.12-1.7.el6.x86_64
Examining glibc-common-2.15-60.el6.x86_64.rpm: glibc-common-2.15-60.el6.x86_64
Marking glibc-common-2.15-60.el6.x86_64.rpm as an update to glibc-common-2.12-1.7.el6.x86_64
Examining glibc-devel-2.12-7.2.x86_64.rpm: glibc-devel-2.12-7.2.x86_64
Marking glibc-devel-2.12-7.2.x86_64.rpm as an update to glibc-devel-2.12-1.7.el6.x86_64
Marking glibc-devel-2.12-7.2.x86_64.rpm as an update to glibc-devel-2.12-1.7.el6.i686
Examining glibc-devel-2.15-60.el6.x86_64.rpm: glibc-devel-2.15-60.el6.x86_64
Marking glibc-devel-2.15-60.el6.x86_64.rpm as an update to glibc-devel-2.12-1.7.el6.x86_64
Marking glibc-devel-2.15-60.el6.x86_64.rpm as an update to glibc-devel-2.12-1.7.el6.i686
Examining glibc-headers-2.15-60.el6.x86_64.rpm: glibc-headers-2.15-60.el6.x86_64
Marking glibc-headers-2.15-60.el6.x86_64.rpm as an update to glibc-headers-2.12-1.7.el6.x86_64
Examining glibc-static-2.12-7.2.x86_64.rpm: glibc-static-2.12-7.2.x86_64
Marking glibc-static-2.12-7.2.x86_64.rpm to be installed
Examining glibc-static-2.15-60.el6.x86_64.rpm: glibc-static-2.15-60.el6.x86_64
Marking glibc-static-2.15-60.el6.x86_64.rpm to be installed
Examining glibc-static-2.18-12.fc20.x86_64.rpm: glibc-static-2.18-12.fc20.x86_64
Marking glibc-static-2.18-12.fc20.x86_64.rpm to be installed
Resolving Dependencies
--> Running transaction check
---> Package glibc.x86_64 0:2.15-60.el6 set to be updated
--> Processing Dependency: glibc-common = 2.12-1.7.el6 for package: glibc-2.12-1.7.el6.i686
---> Package glibc-common.x86_64 0:2.15-60.el6 set to be updated
---> Package glibc-devel.x86_64 0:2.15-60.el6 set to be updated
--> Processing Dependency: glibc-headers = 2.12-1.7.el6 for package: glibc-devel-2.12-1.7.el6.i686
---> Package glibc-headers.x86_64 0:2.15-60.el6 set to be updated
---> Package glibc-static.x86_64 0:2.12-7.2 set to be updated
--> Processing Dependency: glibc-devel = 2.12-7.2 for package: glibc-static-2.12-7.2.x86_64
---> Package glibc-static.x86_64 0:2.15-60.el6 set to be updated
---> Package glibc-static.x86_64 0:2.18-12.fc20 set to be updated
--> Processing Dependency: glibc-devel = 2.18-12.fc20 for package: glibc-static-2.18-12.fc20.x86_64
--> Finished Dependency Resolution
Error: Package: glibc-static-2.18-12.fc20.x86_64 (/glibc-static-2.18-12.fc20.x86_64)
           Requires: glibc-devel = 2.18-12.fc20
           Installed: glibc-devel-2.12-1.7.el6.i686 (@server)
               glibc-devel = 2.12-1.7.el6
           Removing: glibc-devel-2.12-1.7.el6.x86_64 (@anaconda-RedHatEnterpriseLinux-201009221801.x86_64/6.0)
               glibc-devel = 2.12-1.7.el6
           Updated By: glibc-devel-2.15-60.el6.x86_64 (/glibc-devel-2.15-60.el6.x86_64)
               glibc-devel = 2.15-60.el6
Error: Package: glibc-static-2.12-7.2.x86_64 (/glibc-static-2.12-7.2.x86_64)
           Requires: glibc-devel = 2.12-7.2
           Installed: glibc-devel-2.12-1.7.el6.i686 (@server)
               glibc-devel = 2.12-1.7.el6
           Removing: glibc-devel-2.12-1.7.el6.x86_64 (@anaconda-RedHatEnterpriseLinux-201009221801.x86_64/6.0)
               glibc-devel = 2.12-1.7.el6
           Updated By: glibc-devel-2.15-60.el6.x86_64 (/glibc-devel-2.15-60.el6.x86_64)
               glibc-devel = 2.15-60.el6
Error: Package: glibc-devel-2.12-1.7.el6.i686 (@server)
           Requires: glibc-headers = 2.12-1.7.el6
           Removing: glibc-headers-2.12-1.7.el6.x86_64 (@anaconda-RedHatEnterpriseLinux-201009221801.x86_64/6.0)
               glibc-headers = 2.12-1.7.el6
           Updated By: glibc-headers-2.15-60.el6.x86_64 (/glibc-headers-2.15-60.el6.x86_64)
               glibc-headers = 2.15-60.el6
Error: Package: glibc-2.12-1.7.el6.i686 (@server)
           Requires: glibc-common = 2.12-1.7.el6
           Removing: glibc-common-2.12-1.7.el6.x86_64 (@anaconda-RedHatEnterpriseLinux-201009221801.x86_64/6.0)
               glibc-common = 2.12-1.7.el6
           Updated By: glibc-common-2.15-60.el6.x86_64 (/glibc-common-2.15-60.el6.x86_64)
               glibc-common = 2.15-60.el6
 You could try using --skip-broken to work around the problem
libstdc++-4.4.6-4.el6.i686 is a duplicate with libstdc++-4.4.4-13.el6.x86_64
[root@xilinx Downloads]# 
7
  • Can you post the full output of yum install glibc* without --skip-broken?
    – Banjer
    Apr 17, 2014 at 12:53
  • @Banjer updated. Kindly see Apr 17, 2014 at 12:59
  • thanks, can you run it again without --skip-broken? I see it's still in your command. Also, what distro and version are you running?
    – Banjer
    Apr 17, 2014 at 13:25
  • @Banjer Sorry. Now I have given without --skip-broken Apr 17, 2014 at 13:29
  • @Banjer [root@xilinx Downloads]# uname -r 2.6.32-71.el6.x86_64--rhel 6 Apr 17, 2014 at 13:30

1 Answer 1

4

It is obvious you have messed the version of packages and messing packages version is not really good for any of linux distros if you don't know how to deal with dependencies.

As you can see you have multiple version of the same tool installed and the system doesn't really know how to satisfy dependencies seeing different versions.

looking at your output you have:

glibc-devel = 2.18-12.fc20
glibc-devel = 2.15-60.el6
glibc-devel = 2.12-1.7.el6

As you can see you have 2 different version of the same tool installed (the 2nd and 3rd) the 1st one is the one that the repo is trying to update.

One thing you can do is to remove the oldest versions of glibc (or remove it completely) and then try to deinstall them.

If you can't manage to remove it then do as follow:

  yum install yum-utils
  yum update yum*
  package-cleanup --dupes
  package-cleanup --cleandupes

hopefully this will clean up the mess.

Post your further issues here if you have any.

Good luck

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.