In my CentOS 6.0 system, working since months, suddenly stop authenticating non-root users, in graphical mode.

  • I have checked necessary /etc/pam.d/* files, but those are unchanged.
  • SELinux is disabled.
  • I have also tried configuring autologin, but the cursor starts rotating in wait state and nothing is happening beyond that.
  • I have also changed Graphical Display Manager from GDM to KDE, but the problem is same.
  • The problem is same after creating new user and trying to login with that.
  • There also problem login remotely by ssh for the same non-root users.
  • I am also getting 'system is going to halt in 1 min' message along with 'authentication failure' message, when entering password for any user.

There is no problem with root user. And there is no problem login to any user from terminal. Any suggestion?

closed as off-topic by Gilles, terdon, Braiam, jasonwryan, strugee Apr 17 '14 at 0:51

This question appears to be off-topic. The users who voted to close gave this specific reason:

  • "Questions describing a problem that can't be reproduced and seemingly went away on its own (or went away when a typo was fixed) are off-topic as they are unlikely to help future readers." – Gilles, terdon, Braiam, jasonwryan, strugee
If this question can be reworded to fit the rules in the help center, please edit the question.


There was some corruption in my file system. I just booted system by inserting rescue disk and then checked file system with e2fsck, and restarted the system. This solved my issue.

Not the answer you're looking for? Browse other questions tagged or ask your own question.