3

I'm using Debian Jessie with Xfce and cannot login into the GUI as a normal user, root works. I can login on another terminal. I tried to reinstall lightdm, but I still cannot login. After a login attempt, dmesg tells me

systemd-logind[2638]: New session c4 of user lightdm.
systemd-logind[2638]: Linked /tmp/.X11-unix/X0 to /run/user/110/X11-display.
systemd-logind[2638]: Removed session c2.

How can I get more information about what's going wrong? What could prevent me from login in?

  • What happens when you try to log in? Does the screen go blank for a second and then you are returned to the login screen? Could you post the contents of your ~/.xsession-errors file? – terdon Apr 16 '14 at 10:51
  • Yes, that's what happens. I don't have the file ~/.xsession-errors. I do have /root/.xsession-errors though. – pfnuesel Apr 16 '14 at 11:00
  • Well, this kind of thing is usually related to errors in your shell's configuration files. Try renaming ~/.profile, ~/.bash_profile and ~/.bash_login and then logging in. Does that help? Do you have any other desktop environments installed? If so, can you login to those? – terdon Apr 16 '14 at 11:05
  • try creating new user and check can you login with that. – Tejas Apr 16 '14 at 11:17
  • Thanks for your help, guys. I was able to log in with a new user, so I figured something in my home directory must be wrong. I then ran sudo chown -hR username:username /home/username/ and I'm now able to log in again. – pfnuesel Apr 16 '14 at 11:30
2

The fix for me was to chmod +x this file:

/etc/X11/Xsession

Source: https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=748944#27

0

HOW TO ENABLE GUI ROOT LOGIN IN DEBIAN 9

First open a terminal and type su then your root password that you created when installing your Debian 9. Install Leafpad text editor which allows you to edit text files. Type: “apt-get install leafpad” Stay in root terminal and type “leafpad /etc/gdm3/daemon.conf”. This command opens the file “daemon.conf” in leafpad. Under security type “AllowRoot=true”. So your security section in the file should look like this:[security] AllowRoot=trueOnce it looks like this save the file then exit the window. Stay in root terminal and type “leafpad /etc/pam.d/gdm-password”. This command opens the file “gdm-password” in leafpad. Within this file you have comment out the line containing “auth required pam_succeed_if.so user != root quiet_success” so that it looks like this

auth required pam_succeed_if.so user != root quiet_successSave the file and exit.

Now you should be able to login as root in you GUI Debian 9.

To enable CLI or Terminal Login do as below:

vim /etc/ssh/sshd_config and then make sure that you remove a “#” sign and change the line that starts with #PermitRootLogin 'something somethin as in whatever u see’ to ‘PermitRootLogin yes' without the quotes

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.