1

The Postfix server is used only for mail-relay; in the office back-end, we use hMailServer. Some hMailServer users have their emails auto-forwarded to their BlackBerry account. Sometimes, they changed their BlackBerry operator without informing IT Dept. As a result, the auto-forward (handled by Postfix) failed, and a notification is sent (by Postfix) back to the user's account, which gets re-forwarded to the (no longer active) BlackBerry account, another failure, and ... well, you get the idea: A mailing loop.

I need to prevent this from happening. For complex reasons, we can't change our current setup of a separate internal mail server and the cloud-based Postfix mail-relay. So, I must either reconfigure Postfix or use some other mail-relay system that can be configured as such.

1

Based on the title, I think the bounce_size_limit option might help. Try setting it to 0.

Based on the question body, I think you need something else.

Is this what's happening?

1. hMail ---> Postfix (OK)
2. Postfix ---> BlackBerry (Fails)
3. Postfix ---> hMail (OK)
4. hMail ---> Postfix (loop)
etc.

If so, you could append a header to the message as it's being forwarded at step 2, then see if that header is present at step 4.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.