2

Since I upgraded to Gnome Shell 3.12 on ArchLinux x86_64, shell animations (i.e. windows overview) became very jerky on my Intel HD graphics 3000.
This happens with both latest kernel 3.14.1 and previous 3.13.8.

Is there any xorg or other config settings to set, that would resolve this problem?

Edit: As it seems I'm not alone with this issue, I reported a bug here. Let's see what developers say...

1
  • Same problem with archlinux + gnome shell 3.12 . I also have a intel HD 4000.
    – mavillan
    Apr 15 '14 at 18:28
4

I was facing the exact same issue running Gnome Shell 3.12 on ArchLinux x86_64 with an Intel HD 4000 and it looks like I just found a solution (well, at least for me).

Basically all I did was adding the TearFree option to my /etc/X11/xorg.conf.d/20-intel.conf. I had it already created earlier in order to enable SNA acceleration, which I then disabled again due to a lack of any noticeable performance improvement.

Anyhow, this is what it looks like:

Section "Device"
   Identifier  "Intel Graphics"
   Driver      "intel"
#  Option      "AccelMethod"  "sna"
   Option      "TearFree"    "true"
EndSection

And Bam! - smooth sailing from here on.

I stumbled upon this more or less completely by accident, so I'm not really sure whether this a fix or rather a dirty hack, but like I said, it did the trick for me quite nicely.

So from all I can tell, this seems to be an framerate/vsync related issue (with Mutter running on 60 fps via default)?

1

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.