7

I have an Arch linux box that is almost running perfectly but when i connect to the vncserver and the sreensaver turns the screen black, i am forced to reenter the password on the loginscreen of gnome but! and here is the problem, this screen is constantly refreshed so i can't type more than two letters.

I keep every package updated with pacman -Syu. I use tigervnc in version 1.3.1.1. The connection is running over SSH. Gdm in version 3.12.0-1.

Can anyone help here?

~/.vnc/xstartup:

#!/bin/sh
export XKL_XMODMAP_DISABLE=1
exec gnome-session
  • How are you running vnc server? Did you exported flag export XKL_XMODMAP_DISABLE=1for example? – IBr Apr 15 '14 at 10:47
  • Yes. I have already exported it. – simonides Apr 15 '14 at 11:15
  • Then I don't know, I used tigervnc only for new sessions (ie. remote machine without running real xserver). When I needed to have a desktop shared with gdm I used x11vnc with gdm's Xauthority passed as argument and that worked like a charm. What else could be wrong with tigervnc I have no idea. – IBr Apr 16 '14 at 7:00
0

Even I searched a lot, but could not find a satisfactory answer on web. Here are possible workaround if you are unable to enter a password in vnc-client:-

  • Press any Key to reach password field
  • Use the Keyboard mouse to drag the locked screen from bottom to top direction
  • well this question is some years old now. the problem wasn't that the password field was not there, the screwn was reloaded so fast the password field always got cleared before I could finish typing. – simonides Feb 16 '19 at 9:11
0

I just started having this problem a week ago on ubuntu 18.04 (I use vnc on a daily basis), and haven't found a good answer for why it has suddenly started. Especially given that I didn't perform any updates and have auto updates turned off.

However, I seem to have found a workaround: if I start a second instance of vnc I can connect to it and the login screen behaves normally. The login screen continues to work normally on the second vnc instance after killing the 1st. I changed nothing in the 'xstartup' between the two instances. I have no idea why it works, but it does...

  • 1
    I know this but we want the original window. The new window has no history .. what is vnc good for? – Chan Kim Sep 25 '20 at 6:19
0

I encountered the same symptoms on my system. On CentOS 7.7, when starting tigervnc server service I was getting the following error message:

# systemctl start vncserver@:1
Job for vncserver@:1.service failed because a configured resource limit was exceeded. See "systemctl status vncserver@:1.service" and "journalctl -xe" for details.

(but vnc server actually worked without issues). The error message was caused by the recent updates to systemd in CentOS 7.7:

https://access.redhat.com/solutions/4420581

I tried to follow the workaround instructions (in the link above) by changing -l to to -u and removing -c in runuser in /etc/systemd/system/vncserver@\:1.service file. This eliminated the systemd error message but created the issue described in this question: the user password field in the VNC client window was reset/refreshed so frequently that there was no way to login into the machine!

Changing things back in /etc/systemd/system/vncserver@\:1.service solved the issue with the screen refresh. So, my suggestion would be to ensure that you start vncserver with runuser -l <user> -c .... Seems like some environment variable might not get reset if -l is not used and this manifests in the frequent screen refresh...

Hope this is helpful...

0

I also am having this problem. I believe it only happens if you are using GNOME and GDM.

My "workaround" was to install LightDM instead of GDM (still running GNOME) and i3lock. This solved the problem, but is a little more hinky than the native GNOME and GDM lockscreen.

If anyone comes up with a native solution, please post it here.

  • You can also workaround by installing xautolock and i3lock and disabling the GNOME lockscreen function. Unfortunately, this issue persists in GNOME 3.36 - which has a really nice blurred lockscreen. – Rsync Mar 10 '20 at 17:21

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.