This is, perhaps, a bit of a bizarre one but I don't even know where to start looking so if anyone can point me in the right direction, I'll be very grateful.

I've just done a fresh install of my distribution, which included moving to the next release (yup, it's Ubuntu) and so am rebuilding/installing a load of stuff that I usually have in addition to whatever the distribution provides (latest versions and so forth). Anyway, I was merrily doing so with one (a slightly customised version of emacs) when I found make complaining a lot. Looking at the makefile(s), I found that the configure script hadn't put any "continuation line" characters in.

The configure script is rather long (this is emacs, after all) and just searching for \ is rather pointless! So does anyone have any idea why this might be happening?

(As I said, it's a fresh install so maybe it's just some package that I forgot to install. But it's a bit bizarre.)


Here's a guess that may or may not be right.

  • Hypothesis: You've already configured and built Emacs in that directory before the upgrade.
  • Hypothesis: Your shell (/bin/sh) changed during the upgrade.
  • Hypothesis: Emacs caches some data about the shell.

If these hypotheses are true, the configure script may have cached information about your shell's handling of backslashes. There are incompatibilities between shells in that respect, in particular with the echo built-in, so if the cache contains outdated information, the output could be missing backslashes or have doubled backslashes.

Run make distclean to wipe the cache and try again.

  • Unfortunately, I can't run make distclean due to the aforementioned problem with the makefile! So I wiped the directory and reloaded it (I'm not familiar enough with the DVCS used to revert to pristine) but I still get the same problem. I'm now trying under bash (I use zsh normally) ... nope, same problem. May 3 '11 at 19:02
  • @Andrew: I'm afraid you're going to have to link to the precise source you're trying to compile (a tag in the bazaar repository? With custom patches?). May 3 '11 at 19:30
  • @Gilles: I've just tried a version that I know used to work (as it's the one I compiled before I updated my machine) so I strongly suspect that there's a problem on my system. I think that what I need to do is find a small example to test of a configure script (do you happen to know any?). If you really want to know what I'm trying to compile, it's the tiling version of emacs available here: arch.savannah.gnu.org/archives/emacs/emacs/emacs--tiling/… (I made some notes on what to do: math.ntnu.no/~stacey/HowDidIDoThat/Unix/Transparent_Emacs.html ) May 3 '11 at 20:36
  • @AndrewStacey: Does running the configure script as bash ./configure or ksh ./configure make a difference? Try running bash -x ./configure or ksh -x configure to see a trace of what the shell is doing. Add the trace to your question if you need help understanding it. May 3 '11 at 20:47
  • @Gilles: Running under bash didn't make a difference. I'll try with the -x switches tomorrow (I just tried and the output was rather long, and it's rather late here, so I'll take another look tomorrow). Thanks for your help so far! May 3 '11 at 21:01

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.