I'm running the testing branch of with codename Jessie and as desktop environment on a Lenovo ThinkPad T410. When I press the mute-button, it mutes pulse-audio and alsa, but when I press the mute-button again it unmutes pulse-audio but not alsa. I can happily mute and unmute in the terminal by

amixer set Master toggle

Now I'd like to set this command to be executed when pressing the mute button. has a setting for that, it works for other buttons, but not the mute button. In .config/xfce4/xfconf/xfce-perchannel-xml/xfce4-keyboard-shortcuts.xml I have the line

<property name="XF86AudioMute" type="string" value="amixer set Master toggle"/>

but to no avail. Does anyone know how I can either turn off the mute button or overwrite what happens when I press it?



load-module module-alsa-sink
load-module module-alsa-source device=hw:1,0

in /etc/pulse/default.pa did the trick.

Edit: However, after uncommenting the lines mentioned above, I ran into all sorts of problems, for example started crashing. I now removed the complete folder /etc/pulse/ and now everything seems to work fine, including sound and mute button.


I found this solution on a blog to work on my Debian Jessie / XFCE machine.

In brief, the problem seems to be a missing "gstreamer0.10-pulseaudio" package. This causes a behavior where you can mute all audio using the keyboard button, but to unmute it you have to go into alsamixer and press M to unmute; the unmute action apparently doesn't get communicated by default.

  1. sudo apt-get install gstreamer0.10-pulseaudio
  2. Reboot (might be sufficient to restart X, but I just rebooted)
  3. Verify the output of xfconf-query -lc xfce4-mixer to ensure that PlaybackBuiltinAudioAnalogStereoPulseAudioMixer is listed.
  4. The author recommends running xfconf-query -c xfce4-mixer -p /active-card -s PlaybackBuiltinAudioAnalogStereoPulseAudioMixer to set Pulseaudio as the "active card", but this doesn't seem to be necessary and throws an error for me when I tried ("Property "/active-card" does not exist on channel "xfce4-mixer".)

Note that I previously implemented the first part of Michael Tomkins' proposed solution (mapping amixer set Master toggle to the keyboard mute button in the xfce4-menu settings control), so that may be related and is worth a try. I did not remove any of the gstreamer components, and don't recommend doing so given the number of things in Jessie that are (apparently) dependent on them.

  • 4. worked for me with /sound-card instead of /active-card, things where renamed apparently... – OlivierBlanvillain Dec 22 '16 at 10:07

Added (not sure step important)

 xfce4-menu -> Settings -> Settings Manager -> keyboard
 Application Shortcuts
 <Command:> amixer set Master toggle <Ok>
 <Press volume toggle button>

Open Audio Mixer and check that both Master and Speaker are toggling, if so finish.

Was only Toggling Master, speaker was just turning on not off. I noticed on Jessie that both

ii  gstreamer0.10-plugins-bad:amd64       0.10.23-7.1                        amd64        GStreamer plugins from the "bad" set
ii  gstreamer0.10-plugins-base:amd64      0.10.36-1.1                        amd64        GStreamer plugins from the "base" set
ii  gstreamer0.10-plugins-good:amd64      0.10.31-3+nmu2                     amd64        GStreamer plugins from the "good" set
rc  gstreamer0.10-plugins-really-bad      0.10.22-0.1                        amd64        GStreamer plugins from the "bad" set
ii  gstreamer0.10-plugins-ugly:amd64      0.10.19-2+b3                       amd64        GStreamer plugins from the "ugly" set
ii  gstreamer0.10-pulseaudio:amd64        0.10.31-3+nmu2                     amd64        GStreamer plugin for PulseAudio
ii  gstreamer1.0-plugins-base:amd64       1.2.3-1                            amd64        GStreamer plugins from the "base" set
ii  gstreamer1.0-plugins-good:amd64       1.2.3-1                            amd64        GStreamer plugins from the "good" set
ii  gstreamer1.0-plugins-ugly:amd64       1.2.3-2                            amd64        GStreamer plugins from the "ugly" set

were present.

Tried removing gstreamer0.10 which had too many dependencies. So

aptitude purge gstreamer1.0-plugins-base gstreamer1.0-plugins-good  gstreamer1.0-plugins-ugly

Didn't touch libgstreamer1.0-0 or libgstreamer-plugins-base1.0-0

The above also fixes plugging/unplugging headphones AND speaker toggle.

Worked for me.

  • I have too many dependencies on both gstreamer0.10 and gstreamer1.0 to purge them from my system. – pfnuesel Apr 14 '14 at 11:08
  • Just noticed that I now have 3 rather than 6 menus in Audio Mixer. This looks like a wait for the patch/bug fix. – Michael Tomkins Apr 14 '14 at 11:18

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.