Ok so this is exactly what I did yesterday, and what I have tried to solve the problem so far. The distribution is Ubuntu Server 12.04.

What I have done just before the error appeared

  1. I added a new Upstart file in /etc/init
  2. I rebooted the system to see if the script worked
  3. The script did not work, so I edited it and rebooted again

What is happening

And that's where havoc began. I tried sshing into the machine only to be greeted by error messages about not being able to connect. So I go on the server itself and I see that the boot process is hanging at switching to clocksource tsc. I hear the machine working but nothing happens, not even if I leave the server sitting for minutes. The only thing I seem to be able to do is to launch recovery mode.

What I have tried so far

I have googled around a while but nothing seems to solve this problem. Also, in many discussions I have read that users have not been able to solve this, so I am starting to lose hope.

What I have tried so far:

  1. Booted into recovery mode, accesses a root shell and deleted the Upstart script
  2. Took out my nVidia graphics card (one of the discussions I have read online seemed to hint at a problem with this) and used the integrated graphics card
  3. sudo apt-get update && apt-get upgrade, just to make sure there weren't any broken packages or missing dependencies
  4. sudo apt-get dist-upgrade, just to make sure it wasn't a kernel problem
  5. Edited /boot/grub/grub.cfg adding clocksource=hpet to the Ubuntu menu item
  6. Edited /sys/devices/system/clocksource/clocksource0/current_clocksource' from tsctohpet`
  7. Uninstalled all nvidia drivers: sudo apt-get purge nvidia*

None of these worked. The system is now ostensibly in the same state it was before the introduction of the Upstart script (which, to be honest, might not even be the problem after all).

Some extra information

I have found out that booting into recovery mode and selecting "resume boot" works (i.e. I am able to log into the machine), but when I reboot to launch the normal boot, the shutdown hangs as well.

Also, this is /var/log/boot.log:

Begin: Loading essential drivers ... done.
Begin: Running /scripts/init-premount ... done.
Begin: Mounting root file system ... Begin: Running /scripts/local-top ... done.
Begin: Running /scripts/local-premount ... done.
Begin: Running /scripts/local-bottom ... done.
Begin: Running /scripts/init-bottom ... done.
fsck from util-linux 2.20.1
/dev/sda1: clean, 414994/15138816 files, 43972717/60527360 blocks
Skipping profile in /etc/apparmor.d/disable: usr.bin.firefox
Skipping profile in /etc/apparmor.d/disable: usr.sbin.rsyslogd
 * Starting modem connection manager^[[74G[ OK ]
 * Starting mDNS/DNS-SD daemon^[[74G[ OK ]
 * Starting bluetooth daemon^[[74G[ OK ]
 * Starting NetBIOS name server^[[74G[ OK ]
 * Starting network connection manager^[[74G[ OK ]
 * Starting AppArmor profiles       ^[[80G
^[[74G[ OK ]
 * Stopping System V initialisation compatibility^[[74G[ OK ]
 * Starting System V runlevel compatibility^[[74G[ OK ]
 * Starting ACPI daemon^[[74G[ OK ]
 * Starting anac(h)ronistic cron^[[74G[ OK ]
 * Starting save kernel messages^[[74G[ OK ]
 * Starting regular background program processing daemon^[[74G[ OK ]
 * Starting deferred execution scheduler^[[74G[ OK ]
 * Stopping save kernel messages^[[74G[ OK ]
 * Starting LightDM Display Manager^[[74G[ OK ]
 * Starting CPU interrupts balancing daemon^[[74G[ OK ]
 * Stopping Send an event to indicate plymouth is up^[[74G[ OK ]

So nothing wrong in here.

And here is /var/log/syslog: http://pastebin.com/aDNbvTyp

Request for help

Now before I throw my hopes away for good and restore/reinstall, has this happened to any of you before? Any other suggestions on how to solve this?

  • In fact, your system is not hanging on "switching to clocksource tsc" but on the step after! The one that takes a long long time to get printed. Could you give the boot log? Look for /var/log/boot.log or do a grep "Apr 14" /var/log/messages. – lgeorget Apr 14 '14 at 7:35
  • For the record, I had the same problem on my gentoo because the firmware for my graphics card was not loaded. Depending on your distro's boot procedure, the problem may totally different. – lgeorget Apr 14 '14 at 7:38
  • @lgeorget ok, will do that as soon as I get home. Btw, how did you solve your problem? – user1301428 Apr 14 '14 at 8:28
  • I recompiled my kernel with the correct firmware. You're not going to need that on Ubuntu. :-) – lgeorget Apr 14 '14 at 8:32
  • @lgeorget I have updated the question adding the contents of /var/log/boot.log. Also, I don't have /var/log/messages – user1301428 Apr 14 '14 at 15:59

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.