Recently, I got a new laptop, the MSI gx60. I grabbed a usb and loaded the Linux Mint 16 Cinnamon image onto it, tested it on my old laptop and desktop, where it worked. However, when I try it on my laptop it fails in the strangest way:

I put in the usb and turned on the laptop. Entered into the boot menu and selected my USB from the menu. I was then sent to a grub screen(I do NOT have grub installed on my laptop) with the following options: -Launch Linux Mint -Launch Linux Mint in compatibility mode

When I run one of these options, the screen goes black, still on, just displaying black and stays like this forever, until I force a shut down. Now would be a good time to mention that the boot is set to UEFI.

So the next thing I do, is go into BIOS and change the boot to Legacy Mode. Now, when I boot into the same USB device, instead of the grub menu, I get sent into the Linux Mint Menu, just as it should be. However, when I select an option, such as Launching Linux Mint, Instead of taking me the the desktop, as it did on the other computer I tested the USB on, I get a grey screen with a blinking cursor in the top left, followed by a black screen with the top left quarter white, and soon after this the computer goes to the very start of the boot sequence as if it had just turned on.

When I attempted a different USB with a different Linux Image(Kali this time, I get very similar results).

  • 1
    There can be a problem with video graphics card. I am not sure though. This happened with me also with Dell xps machine when i try to install Gentoo. Later i finally found out its the problem with the graphics card(Nvidia), Its not that graphics card is faulty , its just some doesn't support linux OS well. GOD , i love old machines they don't give so many problems.My advise is you should try some more OS , may be ubuntu, fedora,Arch , debian,SUSE. see if one of those works flawlessly, in my case Debian worked. – PKumar Apr 13 '14 at 14:02
  • How long exactly is "forever"? Sometimes it just takes longer than you expect. – Wutaz Apr 13 '14 at 16:15
  • Forever was about 40 mins in my case – Sasha Apr 14 '14 at 0:52

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.