I want to install gcc in my solaris 11 working in virtualbox, I tried

    pkg install gcc-45

but I am getting :

    pkg: 0/1 catalogs successfully updated:

    Unable to contact valid package repository
    Encountered the following error(s):
    Unable to contact any configured publishers.
    This is likely a network configuration problem.
    http protocol error: code: 503 reason: Service Unavailable
    URL: 'http://pkg.oracle.com/solaris/release'

I tried to enter a proxy by entering

     export http_proxy=

But did not work. How can I manage this?


There can be transient network errors between you and the pkg repo server which end up with you being unable to contact the repo server.

A better place to ask this particular question would be the Oracle forums related to Solaris 11. (Try https://community.oracle.com/community/developer/english/server_%26_storage_systems/solaris/solaris_11 to start with).

Does the problem occur if you try again right now? I can get to the search page for the repo server and found http://pkg.oracle.com/solaris/release/p5i/0/developer%2Fgcc-45.p5i very quickly.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.