2

A long time ago in a galaxy far, far away I had fixed boot screen using this nice solution. Since that time I have been looking for the way to move framebuffer in virtual console slightly to the right and down, relatively to X screen position (or vice-versa), because it is shown in wrong position, and part of symbols cannot be seen. I reproduced look and feel of this problem using Crop tool and fbgrab command:

Console Screenshot

The GRUB menu also hides it's left side behind the screen, but I don't know how to make screenshot there without VirtualBox (and I doubt this screenshot will be useful). However, the main X screen shows itself on the correct place (as it seems to me), and my monitor (ACER AL1916) always autotunes to this position, even if virtual console is shown.

I looked in many sources including AskUbuntu, but have found only one solution: switch from VGA cable to DVI, which it is not acceptable, because my graphic card (NVIDIA 6150SE) has only VGA port onboard.

I also found that fbset command can adjust screen parameters but need help for getting how does it work. Here is the output of sudo fbset command:

mode "1280x1024-77"
    # D: 131.096 MHz, H: 80.328 kHz, V: 76.649 Hz
    geometry 1280 1024 1280 1024 32
    timings 7628 160 32 16 4 160 4
    rgba 8/16,8/8,8/0,8/24
endmode

UPD: during reporting non-affected bug found one line that says:

.proc.driver.nvidia.warnings.fbdev:
 Your system is not currently configured to drive a VGA console
 on the primary VGA device. The NVIDIA Linux graphics driver
 requires the use of a text-mode VGA console. Use of other console
 drivers including, but not limited to, vesafb, may result in
 corruption and stability problems, and is not supported.

So, does anyone know how to adjust position of Virtual Console or X screen relatively to each other?

1 Answer 1

2
+100

I'm afraid the core of your problem is very much related to the use of VGA. The problem is that VGA signaling is analog. Basically, the analog signals emitted by the video card on hte VGA port are meant for driving the electromagnetic coils and adjusting the output of the electron gun in an old-school, tube-based monitor. These older monitors didn't have a discrete grid of pixels and rarely was the display flush from edge to edge.

With an LCD which is not an analog device, when using VGA the circuitry in the LCD display has to (I'm simplifying the details here dramatically) basically emulate how an old CRT monitor works to convert the incoming signals into data for each of the LCDs pixels. This is by no means a perfect process and at times the LCD circuitry will have trouble synchronizing to the beginning of the VGA signal scanline. Often, LCD displays with analog inputs will have an "auto-adjust" button that will trigger a "reconfiguration/resynchronization" algorithm inside the display. I'd recommend you check your LCDs manual for details.

This awkward situation is why people who can are encouraged to switch to DVI where the pixel data is transmitted from the video card to the display digitally.

In your type of situation, I've found the problem can often be worked around by changing the resolution and refresh rate used by the video card. For example, at a linux text-console, try the following command:

sudo fbset -a 1280x1024-60

If that works, then that would confirm your LCD is having trouble synchronizing with your video card's output.

I would encourage you to heed the NVIDIA Linux driver's caution and disable the console framebuffer drivers if you mean to use the NVIDIA proprietary driver. If the framebuffer support is important then I'd recommend you consider using the nouveau driver which, given the age of your video card, should work very well.

Good Luck.

1
  • Thanks. The actual problem was in GRUB. For some weird reason it did not update it's config. Any resolution setting in /etc/default/grub was ignored so I could not get /dev/fb0 after boot. After reinstalling it, I was able to set screen resolution and switch to nouveau drivers. However, Unity seems not supporting my hardware so I just keep Xubuntu. I'm happy that this problem is solved, at least partially.
    – Danatela
    May 14, 2014 at 3:49

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .