2

I installed autokey-gtk application but it won't start. When I run it from terminal it will write a message:

Xlib.protocol.request.QueryExtension

but that's all. The application won't start.

Do you know what is wrong?

5
  • On my system, Ubuntu, I get the same message when I start if from the terminal... That message in itself is not an error, because it runs perfectly... It shows up as an icon in my top Panel... The first time I ran it, I too, wondered what was going on...
    – Peter.O
    May 1, 2011 at 17:13
  • Do you know where can I find it if I don't have the top panel in my XFCE? I removed it and have only bottom panel.
    – xralf
    May 1, 2011 at 17:21
  • I added the top panel but this doesn't help.
    – xralf
    May 1, 2011 at 17:35
  • Which distro are you using? .. Autokey's Project homepage (code.google.com/p/autokey) says, KDE and GTK versions available, making AutoKey integrate well into any desktop environment. ... So it should(??) work with XFCE...
    – Peter.O
    May 1, 2011 at 18:23
  • I downloaded xubuntu (XFCE), installed it in a vm (VirurualBox), installed autokey (the transitional package which helps users transition to the autokey-gtk package)... and autokey works fine, so it isn't anything to do with XFCE.
    – Peter.O
    May 1, 2011 at 20:09

2 Answers 2

3

8 years leater, but hopefully still useful for someone. From https://askubuntu.com/a/304834:

The first time you launch AutoKey, it will start the service in the background (the notification icon hasn't been updated for unity, so there's no visual indication). Once it's running, you can bring up the configuration interface by running the launcher again

So, Ubuntu 19.04 I have to type autokey twice from terminal. From dash once is sufficient.

Perhaps also useful: if Autokey does not start at login but you still selected that option, look at https://github.com/autokey/autokey/issues/149

1

On my system, Ubuntu, I get the same message when I start if from the terminal... That message in itself is not an error, because it runs perfectly... It shows up as an icon in my top Panel... The first time I ran it, I too, wondered what was going on

After the initial install, if nothing shows up in your main menu, you can start the Configuration GUI via:

        autokey -c
      or
        autokey --configure
4
  • I had only autokey-gtk. So I installed autokey now. I have only command autokey-gtk -c but this has the same effect.
    – xralf
    May 1, 2011 at 17:34
  • The only other thing I can think of, is just to mention that when I installed autokey, three packages were installed: autokey, autokey-gtk, and autokey-common
    – Peter.O
    May 1, 2011 at 17:44
  • Another thought, but it is only guesswork; you could try using autokey-qt instead... They both work on my system.. The QT version installs autokey-qt autokey-common libqscintilla2-5 python-qscintilla2
    – Peter.O
    May 1, 2011 at 17:51
  • autokey-qt has the same problem.
    – xralf
    May 1, 2011 at 18:22

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .