3

I have a bluetoothmodule here on my UART and would like to use it via hciattach. It is a KC21v6.3 Module from kc-Wirefree. As far I found out, it has a CSR-Chip on it. So is tried the following:

# hciattach -n -s 115200 /dev/ttyS0 csr

That gives me a "Initialization timed out."

If I try the same with the type "any" it works so far that I get a "Device setup complete".

# hciconfig

gives me a:

hci0:   Type: BR/EDR  Bus: UART
        BD Address: 00:00:00:00:00:00  ACL MTU: 0:0  SCO MTU: 0:0
        DOWN 
        RX bytes:22 acl:0 sco:0 events:0 errors:0
        TX bytes:150 acl:0 sco:0 commands:30 errors:0

But after that, when i try to

# hciconfig hci0 up

I always get an

Can't init device hci0: Connection timed out (110)

I have no idea what to try any-more. Don't I have to specify the "csr" chip? Or does it have anything to do with the firmware of my KC21 (it understands AT Commands and also has an "AT HciMode" Command) ... I already tried this one before using the "hciattach" command, but nothing changed.

Any help would be appreciated.

kindly regards Tom

1

Okay, today we found out the solution:

The "problem" was, to set the device in "raw" mode, because of the "AT HciMode" command.

# hciattach -r /dev/ttyS0 bcsp 115200

Maybe it helps somebody.

  • Please share more about your project? – abhiarora Jan 31 '17 at 19:18

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.