0

I am building the 3.14 kernel for a board that requires the intel e1000e driver. I would like this kernel to have the driver built in so that I can remove loadable module support.

I have chosen the option in menu config and verified that the driver is compiled (the .o exists), however the device does not appear to be found or recognized.

Is there something I am missing to add a module to the kernel?

  • There is nothing whatsoever special about builtin drivers. What's the output of dmesg, lspci -k? (Also on a LiveCD where the network card is working). Maybe it needs a different driver after all. – frostschutz Apr 9 '14 at 17:07
  • I checked that first. lspci -k indicates: Kernel driver in use:e1000e – AllenKll Apr 9 '14 at 17:09
1

Apparently there were missing pieces that the driver depended on, that were not auto-selected by the menuconfig. In my case I was missing: pps_core and ptp

I found these by booting a working install with the modules folder renamed. This caused the kernel to not find any loadable modules. Then I tried to insmod the e1000e.ko. This indicated that there were missing PTP module. An attempt at loading that indicated a missing pps driver.

Once all three were loaded, the driver worked. I modified my kernel config to include all three, and it worked right away.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.