First, let me just say that I'm relatively new to Linux, having been forced to use it since the recent death of my hard drive (although having used Linux for a few weeks now, I wish I'd tried it sooner) so I'm probably missing something that should be obvious to more experienced users. Anyway, here's the deal- I finally settled on Linux Mint 16 after trying a few other distributions. I used Unetbootin to create a Live USB with persistence, and it's worked well, except for the fact that after a few days I find that my 8gb USB is almost full. I need my laptop mainly for my online high school classes right now, so I'm not filling it up with games, movies, etc. After exploring my file system I found that while my home folder is full, others like cdrom, tmp, and dev have 1gb+ on them. I ran the command


and got the following:

    Filesystem     1K-blocks    Used Available Use% Mounted on
    /cow             4062908 3323888    529308  87% /
    none                   4       0         4   0% /sys/fs/cgroup
    udev             1744648       4   1744644   1% /dev
    tmpfs            1755620 1232916    522704  71% /tmp
    tmpfs             351124    1316    349808   1% /run        
    none        5120       4      5116   1% /run/lock
    none             1755620     680   1754940   1% /run/shm
    none              102400      12    102388   1% /run/user
    /dev/sda1        7659188 7395068    264120  97% /cdrom
    /dev/loop0       1176448 1176448         0 100% /rofs

Any help would be greatly appreciated!

P.S.- This is my first post, so please excuse me if I formatted something wrong.

Update- After running

    sudo parted -l

I got

    Model: Lexar USB Flash Drive (scsi)
    Disk /dev/sda: 7860MB
    Sector size (logical/physical): 512B/512B
    Partition Table: msdos

    Number  Start   End     Size    Type     File system  Flags
     1      1049kB  7860MB  7859MB  primary  fat32        boot, lba
  • Could you also add the output of sudo parted -l?
    – terdon
    Apr 8, 2014 at 18:24
  • OK, thought so. You only have a single partition, the others are just virtual ones set up by the system. Your main issue is what I explain in my answer, that you are using a tiny 8gb disk for your entire OS so you're running out of space. Fast. Not much you can do about it other than remove large files (only if you know what they are) or installing on your actual computer.
    – terdon
    Apr 8, 2014 at 18:46

1 Answer 1


The issue here is the first entry of the df output:

/cow             4062908 3323888    529308  87% /

That states that your root partition, the one which is the parent folder of everything else, you can think of it as your C: drive, is almost full (87%). The other lines describe separate partitions (think of them as D: drives) and whether or not they are full does not change the fact that / is full.

I can give you more specific advice if you add the output of sudo parted -l but the basic issue is that you are running an OS from an 8GB pen drive. Of course you're running out of space.

To find out what's using the space, you can use a tool like baobab. First install it (it may be included by default, if so, it will be called "Disk Usage Analyzer" in the menu) with sudo apt-get install baobab, then run it with baobab:

enter image description here

Alternatively, use the command line approach:

df -sh / | sort -h

That will list all directories in / sorted by size.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .