5

In Linux Mint 13, when using the Arabic language, text is shown backwards.

I found a possible answer that says I should do:

sudo apt-get install libfribidi0 libfribidi-dev

then install bicon, and then put

Terminal=true
Exec=/usr/bin/bicon.bin

in /usr/share/applications/gnome-terminal.desktop.

After doing this, I restart my computer and enter terminal, but my language is still shown backwards, so then I type in bicon and it fix it.

How can I make terminal work properly without having to type bicon every time?

  • If the possible answer was askubuntu.com/questions/77657/…, you could comment there, and try any solutions suggested in the launchpad bug too. – Mikel Apr 8 '14 at 15:48
  • 1
    When you say "terminal", do you mean Gnome Terminal? How are you starting it? By clicking the icon in the Applications menu, or some other way? – Mikel Apr 8 '14 at 15:50
  • @Mikel yes I start terminal in application menu, also ctrl + alt + t. Terminal is gnome terminal 3.4.1.1 – Guest Apr 8 '14 at 15:57
  • Ctrl + Alt + T doesn't work the same way. Check your Keyboard Settings to see if that runs gnome-terminal or bicon.bin. Sounds like it needs to be the second one. – Mikel Apr 8 '14 at 16:01
  • Does the text look right when you open it from the application menu? – Mikel Apr 8 '14 at 16:01
4

here is a hack I use to make it work. add the folowing to your .bashrc file.

# hack to launch bicon if not launched
if ! [[ "$(ps -p $(ps -p $(echo $$) -o ppid=) -o comm=)" =~ 'bicon'* ]]; then
  bicon.bin
fi

this should also work for new tab. strange behavior happens when you try to open bash inside bash, don't do that.

-1

GNOME Terminal version 3.34 supports right to left scripts such as Arabic, and so do other VTE-based emulators (e.g. Tilix, Terminator, Xfce Terminal, Guake...) if using VTE version 0.58. No need to use bicon anymore.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.