After update/upgrade within Debian/Jessie (affecting some 50 packages) and a reboot (after an uptime of about a month), the full resolution 2560x1440 of my Dell U2713HM has gone. xrandr is listing at most 1920x1200.

Given the long history of my installation, I tried a radical cure, purging all xorg related packages, and reinstalling them. No effect, still limited to 1920x1200.

Then I tried

~$ cvt 2560 1440
# 2560x1440 59.96 Hz (CVT 3.69M9) hsync: 89.52 kHz; pclk: 312.25 MHz
Modeline "2560x1440_60.00"  312.25  2560 2752 3024 3488  1440 1443 1448 1493 -hsync +vsync
~$ xrandr --newmode "2560x1440"  312.25  2560 2752 3024 3488  1440 1443 1448 1493 -hsync +vsync
~$ xrandr --addmode HDMI1 2560x1440
~$ xrandr  --output  HDMI1 --mode 2560x1440
xrandr: Configure crtc 0 failed

The only trace of this in Xorg.0.log is the following:

[  3263.882] (II) intel(0): Allocated new frame buffer 2560x1440 stride 10240, tiled
[  3264.048] (EE) intel(0): failed to set mode: Invalid argument
[  3264.080] (II) intel(0): Allocated new frame buffer 1920x1200 stride 7680, tiled

According to lspci -v, my video device is the following:

00:02.0 VGA compatible controller: Intel Corporation Xeon E3-1200 v3/4th Gen Core Processor Integrated Graphics Controller (rev 06) (prog-if 00 [VGA controller])
    Subsystem: Fujitsu Technology Solutions Device 11e7
    Flags: bus master, fast devsel, latency 0, IRQ 46
    Memory at f7800000 (64-bit, non-prefetchable) [size=4M]
    Memory at e0000000 (64-bit, prefetchable) [size=256M]
    I/O ports at f000 [size=64]
    Expansion ROM at <unassigned> [disabled]
    Capabilities: [90] MSI: Enable+ Count=1/1 Maskable- 64bit-
    Capabilities: [d0] Power Management version 2
    Capabilities: [a4] PCI Advanced Features
    Kernel driver in use: i915

Since I installed the full xorg dependency package, missing drivers is not a likely explanation.

How to proceed?

  • Now also posted at linuxquestions.org/questions/….
    – Joachim W
    Commented Apr 8, 2014 at 15:05
  • 1
    Did you save a copy of the original X logs? You could try comparing them. Also, putting a full copy of your current X logs somewhere (in the question if not too large) might be useful. One obvious is what range of resolutions does the driver currently recognize as valid. Also, asking on the xorg mailing lists might be more effective than here. Commented Apr 8, 2014 at 16:05
  • Range of resolutions does the driver currently recognize as valid: from 1920x1200, 1600x1200, 1680x1050 down to 720x400.
    – Joachim W
    Commented Apr 8, 2014 at 16:38
  • Thank you, @Faheem. I now went to the xorg mailing list.
    – Joachim W
    Commented Apr 8, 2014 at 17:11
  • I looked at your link. You don't have the log for the previous version of your X server, when it was running 2560x1440? Commented Apr 8, 2014 at 23:01

1 Answer 1


The thread https://bbs.archlinux.org/viewtopic.php?id=179120 indicates some recently introduced problem with the Intel driver (see also https://bugs.freedesktop.org/show_bug.cgi?id=75345).

As was to be expected from that discussion, the problem only occurs with DVI cable. After switching to a DisplayPort cable, my full resolution was back.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .