I'm trying to setup the WiFi connection on my Lenovo B590 but I get the following error :

  ifdown: interface wlan0 not configured wpa_supplicant:
  /sbin/wpa_supplicant daemon failed to start run-parts:
  /etc/network/if-pre-up.d/wpasupplicant exited with return code 1
  Internet Systems Consortium DHCP Client 4.2.2 Copyright 2004-2011
  Internet Systems Consortium. All rights reserved. For info, please
  visit https://www.isc.org/software/dhcp/

Cannot find device "wlan0" Bind socket to interface: No such device Failed to bring up work-network

So I looked up which firmware I need so my Debian 7 Wheezy system could find wlan0.

NOTE: the wlan chipset is a Broadcom Corp. BCM43142 and its PCI-ID is 14e4:4365

host@user $ lspci -vnn -d 14e4: |grep Network

02:00.0 Network controller [0280]: Broadcom Corporation BCM43142 802.11b/g/n [14e4:4365] (rev 01)

I found this article on the Debian Wiki giving all the steps needed to get it working, I followed them and got no errors anywhere.

I set up the WiFi interface with wpa_supplicant but when I run

$ ifdown wlan0
$ ifup wlan0=work-network

I still get the error Cannot find device "wlan0" Bind socket to interface: No such device

Do you know what is missing for it to work?

EDIT: below is the dmesg output

$ dmesg |grep broadcom -i                               
[    2.574645] usb 1-1.4: Manufacturer: Broadcom Corp
[    6.828086] eth1: Broadcom BCM4365 802.11 Hybrid Wireless Controller (r300276)
[   10.343512] Broadcom 43xx driver loaded [ Features: PMNLS ]

And here is the content of /etc/network/interfaces

# The loopback network interface
auto lo

# iface lo inet loopback

iface work-network inet dhcp
      wpa-conf /etc/wpa_supplicant/work-network.conf

# The primary network interface
auto eth0
allow-hotplug eth0
  • Are you using /etc/network/interfaces, and if so, can you post the contents of that? If not please state how you are configuring your network. Check also what modules are loaded - you can post the relevant portion of lsmod if you want. Apr 8, 2014 at 14:04
  • I am indeed using /etc/network/interfaces, I will edit with the content of the file.
    – user24156
    Apr 8, 2014 at 14:10
  • This will be easier to debug in chat. You need 20 rep to talk in chat, which you now have. If you want to come over to the main unix.sx chat room, maybe you can get some help there. Ping me from there if you want. Apr 8, 2014 at 15:12
  • A likely source of the problem is the device name wlan0. Where did you get that from? Apr 8, 2014 at 15:20
  • What is the output of iwconfig? Apr 8, 2014 at 15:24

2 Answers 2


If your system is not reporting a device wlan0 as available then the Linux kernel was unsuccessful in detecting your hardware and associating a driver to it. I would start by looking in the dmesg output for any messaging related to the Broadcom device.

If it's being reported there in any way then the appropriate driver is either not present within the kernel/system or it is misconfigured for your particular system.

Finding a driver

Searching a bit on the name of your card + linux yielded this thread titled: Thread: Broadcom BCM43142 Driver Ubuntu 12.10 64 Bit which has details on how to install/configure an appropriate driver for your system.

  • Thank you for your input. I edited my question and added the dmesg output. I stumbled across the thread you linked and already tried it, with no success.
    – user24156
    Apr 8, 2014 at 12:38
  • @ZackDibe - That output is for your ethernet device. It's using driver r300276. Is there nothing about the WiFi then?
    – slm
    Apr 8, 2014 at 13:11
  • It's the whole output of dmesg
    – user24156
    Apr 8, 2014 at 14:09
  • 1
    @ZackDibe - I think eth1 is your wireless device. Notice the bit that says: "Hybrid Wireless Controller". Seems like the WiFi is being assigned this driver instead: r300276. I would do a lspci -vvv and make note of the eth1/WiFi device's output from that command.
    – slm
    Apr 8, 2014 at 15:54

Your interface name is eth1 and not wlan0. Replace wlan0 in all commands with eth1, and it should work.

You must log in to answer this question.