0

How can I enable framebuffer in Debian console?

This is what I've already tried:

  • Add the following lines to the "/etc/default/grub" file:

    GRUB_GFXMODE=1024x768

    GRUB_GFXPAYLOAD_LINUX=1024x768

The following line is commented out

#GRUB_TERMINAL=console
  • I've also add "set gfxpayload=keep" line below "set gfxmode={$GRUB_GFXMODE}" in the "/etc/grub.d/00_header" file.

  • Execute "update-grub"

Nothing happens. I switched to the second virtual console (Ctrl-Alt-2) and tried to execute the following command:

~ $ fbi some_image.jpg
using "DejaVu Sans Mono-16", pixelsize=16.67 file=/usr/share/fonts/truetype/ttf-dejavu/DejaVuSansMono.ttf
open /dev/fb0: No such file or directory

Why? What am I doing wrong? How can I fix it?

  • 1
    Did you reboot? GRUB only sets these settings at boot time. – Graeme Apr 7 '14 at 15:50
  • @Graeme I've thought that "update-grub" command do this. Am I wrong? – FrozenHeart Apr 7 '14 at 15:56
  • Nope, the update-grub command definitely does not reboot your system. – Graeme Apr 7 '14 at 15:57
  • The update-grub script just updates the files in /boot using e.g. /etc/default/grub. It does not reboot your system. – jofel Apr 7 '14 at 15:59
  • @Graeme Nope, I've thought that this command eliminates the need of reboot – FrozenHeart Apr 7 '14 at 16:00

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.