3

To setup automatic wireless connection in Arch, I configured netcfg as directed in the Arch wiki. When I try:

[root@geckko ~]# netcfg adsl

it gives an error:

 > Profile "adsl" does not exist 

The profile does exist as I have checked:

[root@geckko network.d]# ls
adsl  examples  hooks  interfaces

I googled and found this thread in the Arch forum but I'm pretty sure I haven't made the same mistake the author of that thread has made. How can I solve this issue?

Here's the profile:

CONNECTION='wireless'
DESCRIPTION='A simple WPA encrypted wireless connection'
INTERFACE='wlan0'
SECURITY='wpa'
ESSID='essid'
KEY='secretkey'
IP='dhcp' 

And the permissions of the file:

Owner: root
Access: read and write

Group: root
Access: Read-only

Others: read-only

You are not the owner, so you cannot change these permissions.
  • You will need to post your profile (with sensitive information removed, naturally) if you want help with this issue. Also, check the permissions on the file... – jasonwryan Apr 30 '11 at 8:01
  • 1
    It looks OK to me. Try creating another profile with a different name and seeing if you get the same error. Also, make sure you can connect manually. – jasonwryan Apr 30 '11 at 23:00
  • 1
    Tried creating a new profile and it worked :) Thanks. It seems I had created a directory for a profile instead of a file. – user3496 May 1 '11 at 6:31
  • @SamratManSingh: could you post exactly what you did to resolve this as an answer? – Mat Feb 26 '12 at 15:25
1

Try:

sudo netcfg adsl

since the owner and group is root.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy